Closed Bug 1369180 Opened 2 years ago Closed 2 years ago

[css-grid] 'overflow' set on grid item doesn't do anything

Categories

(Core :: Layout, defect)

53 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1348857

People

(Reporter: bfrohs, Unassigned)

Details

(Keywords: testcase)

Attachments

(2 files)

Attached file testcase.html
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170524180630

Steps to reproduce:

Set 'overflow:auto' or 'overflow:hidden' on a grid item with contents that are wider than the grid container.


Actual results:

The grid item expands to fit the contents.


Expected results:

The grid item should cut off the contents that expand outside of the container size (and add a scrollbar if 'auto').
Attached file reftest.html
reftest
Keywords: testcase
Component: Untriaged → Layout
Product: Firefox → Core
It's fixed in Firefox 54 which will be out in a week or so.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1348857
You need to log in before you can comment on or make changes to this bug.