Closed Bug 1369211 Opened 3 years ago Closed 3 years ago

Remove the product dashboard extension as it exists

Categories

(bugzilla.mozilla.org Graveyard :: Extensions: ProductDashboard, enhancement, P1)

Production
enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emceeaich, Assigned: vishalkr.k07, Mentored)

References

Details

(Keywords: bmo-small, good-first-bug)

Attachments

(1 file, 1 obsolete file)

PR
45 bytes, text/x-github-pull-request
dylan
: review+
Details | Review
The current product dashboard does not reflect the metrics which the Product Integrity org uses (blockers, untriaged bugs, time to triage.)

Let's remove the dashboard as it is.

It can be replaced later.
This would be updating an HTML header file to remove the link to Product Dashboard, removing the Bugzilla extension from the source tree, and testing to confirm no regressions. 

:dylan, can you check access logs to see who, if anyone is using this so we can check with them before removing it?
Mentor: ehumphries, dylan
Flags: needinfo?(dylan)
hello, i am new around here. Can I work on this?
Hi Vishal, as soon as we confirm there are no critical uses of this feature, we can review your pull request. 

You can start by forking and cloning https://github.com/mozilla-bteam/bmo, installing virtual box and vagrant, and following the instructions in the readme in the GitHub project. 

Make your changes in your fork, confirm they are working, and submit a pull request. 

Thank you!
Flags: needinfo?(vishalkr.k07)
I have clone the repository and set up on my system. Can you help me with the files that I need to look for?
Flags: needinfo?(vishalkr.k07)
(In reply to Vishal Kumar from comment #4)
> I have clone the repository and set up on my system. Can you help me with
> the files that I need to look for?

The files for the dashboard are in an bugzilla extension at: /extensions/ProductDashboard so that can be removed

Then you'll need to remove the link to "Product Dashboard" in the HTML page header
Discussed with Dylan and this not being used, it's okay to remove this.
Flags: needinfo?(dylan) → needinfo?(vishalkr.k07)
I've removed the product dashboard extension. 
https://github.com/vishalkr07/bmo/commit/0ca9994587e7a2aa2105d54129ed8a82c3a2e88f
Flags: needinfo?(vishalkr.k07)
Attached file PR (obsolete) β€”
Before this goes out, we should have an email and blog post announcing this is going away, that it was a feature which was not being used, and that removing it eliminates a dependency on an unsupported library (YUI 3.)
Flags: needinfo?(dylan)
Comment on attachment 8879104 [details] [review]
PR

carrying's seban's r+ forward. I'm going to commit this after one last check of the logs
Flags: needinfo?(dylan)
Attachment #8879104 - Flags: review?(dylan) → review+
It seems like the dashboard is actually very popular, I'm digging a bit deeper. I think the previous queries against the history were not correct
Flags: needinfo?(dylan)
Okay, may need a comms plan for this. 

Are people looking at the votes pages?
so far I can only place one name to any of the IPs, alta88@gmail.com.

If we were just removing it for the sake of removing it, it would be one thing -- but we're removing it because we arn't going to bother porting it off YUI. So I'll merge this in.
Attached file PR β€”
Had to fix conflicts -- the commit is still vishalkr07's but I can't review it on github.

someone else will need to approve it and then I'll land it (to make sure the commit message is good)
Attachment #8879104 - Attachment is obsolete: true
Attachment #8888036 - Flags: review+
Discussed with #maildev channel, not widely used, okay to remove.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Shame about it - I found especially the list of recently opened/closed bugs quite useful. Although at least *that* feature can be replaced by a corresponding search query, even if it's slightly less comfortable to set up or especially modify than the dashboard.
I agree. This was a very useful feature. I have not seen any longer lasting discussions about it in #maildev channel and I usually check the logs daily. Bummer that it is gone.
If we can crystalize what you liked about it, we could re-implement it in a more maintainable fashion.
Flags: needinfo?(jh+bugzilla)
Flags: needinfo?(frgrahl)
Thanks whould be great.

I didn't use much of it and what I used could be probably put into simple reports. It was just that it was a convenient and standard way to query bugzilla. Doing it via reports always takes longer. I use some of them too for other tasks.

What I did most was to just look at recently opened and closed bugs for Thunderbird, mailnews and SeaMonkey. For these "smaller" products the resultset was always quit small and manageable. Usually the default number of days was ok. Sometimes I did go back 2 weeks but that was seldom the case. I would also like a recently changed report.
Flags: needinfo?(frgrahl)
Basically what Frank said (although for Firefox for Android in my case). Some of the other stuff on it was also somewhat interesting (e.g. the list of bugs having the most duplicates is what I most clearly remember), although to be honest it was more to satisfy my own curiosity.

The thing I was really actively using was indeed the overview of recently opened and closed bugs in a product. Since that feature is also probably the one that can most easily be replaced by a custom search (which I have indeed done now), so I guess a replacement needn't be a particularly high priority. For the record, though, the dashboard had the advantage of making it easier to adjust the time range of the displayed bugs if necessary and also switching products on the occasional instance where I wanted to look at something other than my usual Fennec bugs.
Flags: needinfo?(jh+bugzilla)
Product: bugzilla.mozilla.org → bugzilla.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.