Closed Bug 1369215 Opened 3 years ago Closed 3 years ago

Firefox Nightly hangs when JAWS Screenreader and e10s is active

Categories

(Core :: Disability Access APIs, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1388409

People

(Reporter: u554753, Unassigned)

References

(Blocks 2 open bugs)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
JAWS Version: 18.0.2945

Steps to Reproduce:
1. Go to http://oaa-accessibility.org/example/1 or any website with significant amount of content
2. Observe browser behavior.

Expected Result:
Firefox Nightly does not hang/freeze, functions normally.

Actual Result:
Browser either hangs, or "Firefox Nightly has stopped working" dialog box appears after a time. (See Gecko Profiler link below)


This happens only when e10s is enabled. It functions normally when e10s is disabled.

Gecko Profiler:
https://perfht.ml/2rG3z4E
Thanks for your bug report Grover.  Is this a normal Nightly build?

Markus, any idea why the profile lacks symbols?
Flags: needinfo?(mstange)
I believe we're already tracking similar hangs and are working with the JAWS vendor to resolve. Aaron can say more if need be.
Flags: needinfo?(aklotz)
Normal nightly build as of yesterday.
Yes, the hangs are due to JAWS' injected DLL blocking the chrome main thread while it does a bunch of other stuff. We're working on it in conjunction with the JAWS developers.
Flags: needinfo?(aklotz)
Understood. Going to cite this bug in the QA sign-off report, with reference to Comment 4.
(In reply to :Ehsan Akhgari (needinfo please, extremely long backlog) from comment #1)
> Thanks for your bug report Grover.  Is this a normal Nightly build?
> 
> Markus, any idea why the profile lacks symbols?

Not sure. Symbolication is rather network and memory intensive, and can take some time. Maybe the profile was uploaded before symbolication was finished.
We should just add the ability to perf.html to symbolicate an existing profile, and then we won't need to worry about this as much anymore.
Flags: needinfo?(mstange)
No longer blocks: 1258839
This is still a valid issue, I see long pauses during "slurp" period after loading a fresh, wordy wikipedia page. try - https://en.wikipedia.org/wiki/Westworld_(TV_series)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: jaws-jank
You need to log in before you can comment on or make changes to this bug.