webRequest API produces a non-zero frameId for main frames

RESOLVED DUPLICATE of bug 1367138

Status

RESOLVED DUPLICATE of bug 1367138
a year ago
2 months ago

People

(Reporter: gaubugzilla, Unassigned)

Tracking

(Blocks: 1 bug, {regression, regressionwindow-wanted})

Trunk
regression, regressionwindow-wanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8873317 [details]
Minimal extension for testing

Steps to reproduce:

* Install the attached extension (either as a temporary add-on via about:debugging or by disabling signing requirements).
* Go to https://adblockplus.org/
* Press Ctrl+Shift+J to open Browser Console and look at the log entries prefixed with "**** beforerequest" - these contain the request ID, frame ID and URL for all requests reported via browser.webRequest.onBeforeRequest.

I tested this in Firefox 55.0a1 (2017-05-31 nightly) on Ubuntu.

Expected results:

Requests associated with the main frame have a zero frame ID. Only the requests made by the YouTube frame have a non-zero frame ID. This behavior is documented under https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/webRequest/onBeforeRequest#details

Actual results:

Only the document itself has frame ID 0. All requests made by the document (such as https://adblockplus.org/css/main.css) have a non-zero frame ID, and the requests associated with the YouTube frame merely have a different non-zero frame ID. This behavior is breaking Adblock Plus (the Web Extensions build) because requests cannot be attributed to a document properly.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1367138

Updated

2 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.