Last Comment Bug 136940 - Exit QuickLaunch mode on last window closing if multiple profiles
: Exit QuickLaunch mode on last window closing if multiple profiles
Status: VERIFIED FIXED
[ADT1]
: qawanted
Product: Core Graveyard
Classification: Graveyard
Component: QuickLaunch (AKA turbo mode) (show other bugs)
: Trunk
: x86 Windows 2000
: P1 major (vote)
: mozilla1.0
Assigned To: Bill Law
: Grace Bush
Mentors:
Depends on:
Blocks: 108795
  Show dependency treegraph
 
Reported: 2002-04-11 12:29 PDT by Bill Law
Modified: 2012-10-25 11:16 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
fix (2.22 KB, patch)
2002-04-12 02:29 PDT, Bill Law
morse: review+
bugzilla: superreview+
rjesup: approval+
Details | Diff | Review

Description Bill Law 2002-04-11 12:29:38 PDT
We decided to implement new code that will run when in Quick Launch mode.  This
code will check, at last window closing, whether the user has multiple profiles
defined and if so, automatically exit QuickLaunch mode (and since the last
window is closing, exit Mozilla).

This code will be enabled via a pref that will default to "off."  The plan is to
change this default to "on" (or remove the pref check) if we are unable to get
QuickLaunch working reliably in multi-profile cases.
Comment 1 Bill Law 2002-04-11 12:30:49 PDT
Nominating
Comment 2 Peter Trudelle 2002-04-11 16:56:14 PDT
nsbeta1+/ADT1
Comment 3 Bill Law 2002-04-12 02:29:14 PDT
Created attachment 78870 [details] [diff] [review]
fix
Comment 4 Bill Law 2002-04-12 18:11:16 PDT
Fix is already attached, just needs reviews/approval.
Comment 5 Stephen P. Morse 2002-04-12 18:19:45 PDT
Comment on attachment 78870 [details] [diff] [review]
fix

r=morse
Comment 6 Blake Ross 2002-04-15 22:58:43 PDT
Comment on attachment 78870 [details] [diff] [review]
fix

Looks good. sr=blake
Comment 7 Jaime Rodriguez, Jr. 2002-04-16 18:57:03 PDT
Adding adt1.0.0. Pls land this on the trunk tonight, and have grace verify that
it is resolved and causes no regressions.
Comment 8 Bill Law 2002-04-16 20:44:53 PDT
Landed on trunk.
Comment 9 [:jesup] on pto until 2016/7/5 Randell Jesup 2002-04-17 07:45:31 PDT
Comment on attachment 78870 [details] [diff] [review]
fix

a=rjesup@wgate.com
Comment 10 Jaime Rodriguez, Jr. 2002-04-17 09:51:48 PDT
grace - is this fixed on the trunk? where ther any regressions introduced?
Comment 11 Grace Bush 2002-04-17 10:13:11 PDT
I am waiting for a trunk build for 4/17- this says checked in on 4/16 at 8pm- no 
build since then
Comment 12 (not reading, please use seth@sspitzer.org instead) 2002-04-17 14:21:49 PDT
shouldn't we be defaulting "browser.turbo.singleProfileOnly" to true in all.js?
Comment 13 Bill Law 2002-04-17 17:16:54 PDT
Seth: the plan is to do that if and when we have to give up on fixing the
various multi-profile bugs.  I don't think we're at that point yet.
Comment 14 Peter Trudelle 2002-04-17 18:32:17 PDT
We have give it our best shot, but if we do flip that switch, we need to do so
in time to get adequate testing.
Comment 15 Jaime Rodriguez, Jr. 2002-04-18 11:40:14 PDT
Agreed, we don't believe we are the point to give up on Multiple Profile QL
right now. 
Comment 16 Grace Bush 2002-04-18 13:58:43 PDT
using trunk build 2002041803 and profiles created with older build- I set pref 
singleProfileOnly to true and got the following results- as expected

single profile, pref is enabled and reg key set 
launch and test, systray icon appears and process can be seen in task manager.
did usual turbo testing- closed app and systray icon remained as did process

multiple profiles: pref is enabled and reg key set from installation checkbox
launch and test, systray icon appears and process can be seen in task manager.
closed app and systray icon was removed as was process.  reg key still set.  On
next launch of same or different profile, systray icon returned with the process

so with this pref set, QuickLaunch (aka Turbo)settings as reg key and pref will
remain set, but the app will shut down when multiple profiles are present
Comment 17 scottputterman 2002-04-18 16:27:01 PDT
adding adt1.0.0+ assuming that this bug is needed with the plan to have turbo
shut down and spawn a new process on exit.

If it is then please check this in as soon as possible and add the fixed1.0.0
keyword.
Comment 18 Peter Trudelle 2002-04-18 17:18:00 PDT
I don't think it should be needed for spawn/shutdown, this is our worst-case
fallback option.
Comment 19 Peter Trudelle 2002-04-27 19:16:49 PDT
Hasn't this already landed on trunk and branch?  Do we just need to set the pref
to resolve it?
Comment 20 Peter Trudelle 2002-04-28 01:42:38 PDT
Grace, how thoroughly has this been tested?
Comment 21 Grace Bush 2002-04-29 07:54:59 PDT
I have not seen notification that this has landed on branch- (fixed1.0.0 
keyword) 
I did test on trunk (comment 16) using the basic functional tests and other 
tests listed on http://slip/projects/machv/turboindex.html

Comment 22 Bill Law 2002-04-29 17:26:01 PDT
fix checked in, trunk and branch

We'll use another bug to check in the all.js change to turn the pref on.
Comment 23 Grace Bush 2002-04-30 15:43:11 PDT
verified on trunk (when I set pref) 2002043003
verified on branch 2002043006- pref set in bug 141068

Note You need to log in before you can comment on or make changes to this bug.