Closed Bug 1369564 Opened 2 years ago Closed 2 years ago

[Photon] Menus are too wide.

Categories

(Firefox :: Menus, defect, P1)

55 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 55
Iteration:
55.7 - Jun 12
Tracking Status
firefox55 --- fixed
firefox56 --- verified

People

(Reporter: streetwolf, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [photon-structure])

Attachments

(1 file, 1 obsolete file)

Attached image Wide Menu example (obsolete) —
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170601135542

Steps to reproduce:

Seems that some patch on inbound has just about doubled the width of menus of non-firefox icons on the toolbar. This makes almost half of the menu white space. The last good cset is 001d49708a35. The bad one is e398680c4833. 

I have Photon turned on btw.


Actual results:

Menus from non-Fx icons on toolbar are too wide.


Expected results:

Menus should be normal width.
Attached image Wide Menu example
Fixed image.
Component: Untriaged → Menus
Flags: needinfo?(jaws)
This is a Photon issue.  I set 'browser.photon.structure.enabled' to false and the menus were fine.
Flags: needinfo?(jaws)
Summary: Menus are too wide → [Photon] Menus are too wide.
Whiteboard: [photon-visual]
Not all add-on menus off of their icon are too wide.  On my system uBlock Origin, Zoom Page WE, and partially Text Cache Lite are too wide. My other add-on icon menus look fine.
Whiteboard: [photon-visual] → [photon-visual] [triage]
mozregression tells
 2:58.08 INFO: Last good revision: bdb2387396b4a74dfefb7c983733eed3625e906a
 2:58.08 INFO: First bad revision: d96110d766199d42524558fd83e6467906de4daf
 2:58.08 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bdb2387396b4a74dfefb7c983733eed3625e906a&tochange=d96110d766199d42524558fd83e6467906de4daf

I believe bug 1354155 introduced the regression.

https://hg.mozilla.org/mozilla-central/rev/27e39a0dead1#l5.48
>+      let multiView = document.createElement(gPhotonStructure ? "photonpanelmultiview" : "panelmultiview");

and

https://dxr.mozilla.org/mozilla-central/source/browser/themes/shared/customizableui/panelUI.inc.css#346
>photonpanelmultiview panelview {
>  background: var(--arrowpanel-background);
>  padding: 6px 0;
>  min-width: @menuPanelWidth@;
>}

So, if I applied small value (or "auto") to min-width, the panel is recovered.
>photonpanelmultiview panelview {
>  min-width: 0;
>}

(tested with nightly build 20170603030204 and uBlock Origin 1.12.4, Stylish 2.0.7)
(is that really *min*-width?)
Blocks: 1354155
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8873647 [details]
Wide Menu example

This image seems to be broken?
Attachment #8873647 - Attachment is obsolete: true
The min-width itself was added in bug 1363753. I'm not sure to what degree it's necessary in all panels, or if this selector should have just applied to the main hamburger panel - in which case, I wonder if we'll need to set a min-width on some of the other panels manually to avoid similar bugs as mentioned in bug 1363753 happening. Maybe Mike knows.
Blocks: 1363753
No longer blocks: 1354155
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(mdeboer)
Whiteboard: [photon-visual] [triage] → [photon-structure] [triage]
I'll take a look at this.
Assignee: nobody → mdeboer
Status: UNCONFIRMED → ASSIGNED
Iteration: --- → 55.7 - Jun 12
Ever confirmed: true
Flags: needinfo?(mdeboer) → qe-verify+
I put up a patch in bug 1354109 that addresses it (as webextensions tests fail otherwise).
Whiteboard: [photon-structure] [triage] → [photon-structure]
Assignee: mdeboer → nobody
Status: ASSIGNED → NEW
Iteration: 55.7 - Jun 12 → ---
Priority: -- → P3
QA Contact: gwimberly
Whiteboard: [photon-structure] → [reserve-photon-structure]
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d39d7663a53b
fix min-width issues with panels, r=mikedeboer
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Whiteboard: [reserve-photon-structure] → [photon-structure]
Priority: P3 → P1
Iteration: --- → 55.7 - Jun 12
https://hg.mozilla.org/mozilla-central/rev/d39d7663a53b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Verified on Windows, Mac, and Ubuntu.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Blocks: 1387512
You need to log in before you can comment on or make changes to this bug.