Preferences search shows matched in sub-dialogs when searching numbers

VERIFIED FIXED in Firefox 55

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 months ago

People

(Reporter: MikkCZ, Assigned: rickychien)

Tracking

({nightly-community})

unspecified
Firefox 56
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox55 verified)

Details

(Whiteboard: [photon-preference])

Attachments

(1 attachment)

Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0 ID:20170602100143 CSet: aeb3d0ca558f034cbef1c5a68bd07dd738611494

STR:
1) Open about:preferences with search enabled.
2) Type in "0" or "1".
3) See where the search found the number (mostly in combo box menus, like what to do when Firefox starts).
Flags: qe-verify+
Whiteboard: [photon-preference][triage]
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Priority: -- → P1
QA Contact: hani.yacoub
Target Milestone: --- → Firefox 56
In short, we search algorithm will try to match every keyword appears in node's "label" and "value" attributes. The combo box menus a.k.a dropdown menu uses value = 0,1,2...etc to indicate the order of each item in menu, which causes unexpected result we don't want.

We should tweak the search algorithm to skip searching value attribute when element is dropdown menu.
Comment hidden (mozreview-request)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8874289 [details]
Bug 1369719 - Avoid searching value attribute in menuitem

https://reviewboard.mozilla.org/r/145656/#review149788

::: browser/components/preferences/in-content-new/findInPage.js:300
(Diff revision 1)
>        // Creating tooltips for buttons
>        if (labelResult && nodeObject.tagName === "button") {
>          this.listSearchTooltips.push(nodeObject);
>        }
>  
>        // Searching some elements, such as xul:label, store their user-visible text in a "value" attribute.

Let's add a comment here about why we're skipping menuitem values.
Attachment #8874289 - Flags: review?(mconley) → review+
Comment hidden (mozreview-request)

Comment 5

2 years ago
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3a10169452a5
Avoid searching value attribute in menuitem r=mconley
Whiteboard: [photon-preference][triage] → [photon-preference]
https://hg.mozilla.org/mozilla-central/rev/3a10169452a5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Cannot reproduce in the build today anymore. Thank for fixing.

Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0 ID:20170606100219 CSet: 58ce95bc58ce4ba200413c8bed87786dccf3d105
Status: RESOLVED → VERIFIED

Comment 8

2 years ago
Build ID: 20170612091112
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Verified as fixed on Firefox Nightly 56.0a1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.

Updated

2 months ago
See Also: → 1532931
You need to log in before you can comment on or make changes to this bug.