Closed Bug 1369724 Opened 3 years ago Closed 3 years ago

Fake H264 codec used in mochitests randomly fails causing timeouts

Categories

(Core :: WebRTC: Audio/Video, defect, P1)

49 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

Details

Attachments

(1 file)

The fake H264 GMP codec used only in tests mis-sets the frame size for an iframe, leading to random intermittents in automation.  No impact on real-world usage.

Found while debugging failures for the v57 landing (bug 1341285).
Rank: 15
Priority: -- → P1
MozReview-Commit-ID: 8LOds60sqhN
Comment on attachment 8873825 [details] [diff] [review]
Fix setting size for fake H264 codec

Review of attachment 8873825 [details] [diff] [review]:
-----------------------------------------------------------------

carryover r=jya from bug 1341285
Attachment #8873825 - Flags: review+
Duplicate of this bug: 1123304
Beta patch is the fake codec only, not the changed assertions in WebrtcGmpVideoCodec.cpp; a=test-only
https://hg.mozilla.org/mozilla-central/rev/99cc18bf162a
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.