Thumb overshoots mouse position during press-and-hold on scrollbar track

RESOLVED DUPLICATE of bug 1331390

Status

()

RESOLVED DUPLICATE of bug 1331390
a year ago
a year ago

People

(Reporter: botond, Unassigned)

Tracking

({regression})

Trunk
All
Windows
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

STR:
  1. Load a scrollable page, such as [1].
  2. Click on the scrollbar track, away from the thumb,
     holding the mouse down until the thumb stops moving.

Expected results:

  When the thumb stops moving, it's under the mouse.

Actual results:

  When the thumb stops moving, it has overshot the mouse
  position and is no longer under the mouse.

This was tested on Windows. On Linux, press-and-hold has a different behaviour (the thumb keeps going until the end of the scroll range), although inverting the condition of this #ifdef [2] causes Linux to have the Windows behaviour (including the bug).

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1321428
[2] http://searchfox.org/mozilla-central/rev/972b7a5149bbb2eaab48aafa87678c33d5f2f045/layout/xul/nsSliderFrame.cpp#1432
Mozregression came up with this regression range:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=daa84204a11a&tochange=dc352a7bf234

In that range, bug 957445 seems the most likely culprit. Kip, you are assigned to that bug, do you think it may have caused this?
Flags: needinfo?(kgilbert)
Oh, it looks like bug 1331390 is already on file for the same issue.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(kgilbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1331390
You need to log in before you can comment on or make changes to this bug.