Combine skins/contrib/Mozilla/*.css and skins/custom/*.css into skins/standard/*.css

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Sandstone/Mozilla Skin
P1
normal
RESOLVED FIXED
6 months ago
4 months ago

People

(Reporter: dylan, Assigned: Mary Umoh)

Tracking

Production
Dependency tree / graph

Details

Attachments

(2 attachments)

(Reporter)

Description

6 months ago
I think it will ease the branding effort (among other things) if we can unify the CSS files.

This would mean appending the content of
https://github.com/mozilla-bteam/bmo/blob/master/skins/custom/index.css
https://github.com/mozilla-bteam/bmo/blob/master/skins/contrib/Mozilla/index.css
(in that order)

to the end of https://github.com/mozilla-bteam/bmo/blob/master/skins/standard/index.css

and so on for all the files under skins/custom and skins/contrib/Mozilla.
(Reporter)

Comment 1

6 months ago
As long as the ordering of the rules in the CSS files is the same, this should have no impact.
After this, it should be possible to use CSS developer tools to remove unneeded CSS rules as well.
(Reporter)

Comment 2

6 months ago
note the ordering is standard, then skin, then custom. 

basically, for each one, concatate together and append to the standard one. Like the shell command below:

cat skins/contrib/Mozilla/index.css skins/custom/index.css >> skins/standard/index.css
Summary: Combine skins/contrib/*.css and skins/custom/Mozilla/*.css into skins/standard/*.css → Combine skins/custom/Mozilla/*.css and skins/contrib/*.css into skins/standard/*.css
(Assignee)

Comment 3

6 months ago
Created attachment 8874542 [details] [review]
PR
Attachment #8874542 - Flags: review?(dylan)
(Reporter)

Updated

6 months ago
Priority: -- → P1
(Reporter)

Updated

5 months ago
Summary: Combine skins/custom/Mozilla/*.css and skins/contrib/*.css into skins/standard/*.css → Combine skins/contrib/Mozilla/*.css and skins/custom/*.css into skins/standard/*.css
(Reporter)

Comment 4

5 months ago
Comment on attachment 8874542 [details] [review]
PR

Changes requested in the pull request.
Attachment #8874542 - Flags: review?(dylan) → review-
(Reporter)

Comment 5

5 months ago
Additional review cycled happened, with only one problem. I'm going to open this up for QA on bugzilla-dev so there are a few more eyes to catch changes.
Created attachment 8878217 [details]
Bug List

I found one small thing, the background color is missing from the bug list header.
(Reporter)

Comment 7

5 months ago
This seems to be the case in production as well -- not a bug?
Flags: needinfo?(ehumphries)
Yes, no worries!
Flags: needinfo?(ehumphries)
(Reporter)

Updated

5 months ago
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
(Reporter)

Updated

5 months ago
Attachment #8874542 - Flags: review- → review+
(Reporter)

Updated

5 months ago
Summary: Combine skins/contrib/Mozilla/*.css and skins/custom/*.css into skins/standard/*.css → Combine skins/contrib/Mozilla/*.css and skins/custom/*.css into skins/standard/*.css
(Reporter)

Updated

4 months ago
Blocks: 1380019
(Reporter)

Updated

4 months ago
Blocks: 1380064
You need to log in before you can comment on or make changes to this bug.