Closed Bug 1369940 Opened 3 years ago Closed 3 years ago

nsNavBookmarks::GetBookmarkIdsForURITArray() uses synchronous sqlite

Categories

(Toolkit :: Places, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 519514

People

(Reporter: ehsan, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qf-])

Attachments

(1 file)

239.20 KB, text/plain
Details
Attached file trace
I experienced a long UI pause today on my old OSX machine, unfortunately the Gecko Profiler add-on wasn't activated and I wasn't quick enough to open Instruments but I captured a trace in Activity Monitor.

This comes from <https://searchfox.org/mozilla-central/rev/3efd1caff252061946f0773df68bdd50de5eb756/toolkit/components/places/PlacesUtils.jsm#1335> as far as I can tell.

This looks like main-thread IO to me.  Marco, is that right?  Is this bad?  Do we have a bug for it?
Flags: needinfo?
Flags: needinfo? → needinfo?(mak77)
All the synchronous bookmarking APIs are deprecated in favor of bug 519514, the UI conversion is happening gradually though, I didn't have resources for the migration so I worked with volunteers from the community in these months to bring on the work, but some big pieces are still blocked.
I plan to work on that problem soon, once Firefox 55 is done, maybe even as a sprint for the SF all hands.

And yes almost all the UI touching bookmarks is doing main-thread IO, exactly because the resources for the async bookmarking project were all pulled some time ago to work on other projects, and I could never complete it.

I don't know if you want to keep this open or not, bug 519514 already tracks most of the work.
Flags: needinfo?(mak77)
And bug 979280 is another strict requirement, since the UI goes through the transaction manager, if the transaction manager is synchronous, we can't do much.

Both bookmarks and transactions project are around 70-80% completion.
Flags: needinfo?(mconley)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mconley)
Resolution: --- → DUPLICATE
Whiteboard: [qf] → [qf-]
Duplicate of bug: placesAsyncBookmarks
You need to log in before you can comment on or make changes to this bug.