Closed Bug 1369951 Opened 3 years ago Closed 3 years ago

Use the stored grid highlighter settings for the grid highlighter toggled in the rule view

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox55 fixed)

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: jensimmons, Assigned: gl)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Here's a video of the problem: https://vimeo.com/220095466/74d0edca70


If I turn the Grid Inspector on and off by using the checkbox in the Layout Panel, it remembers what color I set the lines to be.

If I use the icon next to `display: grid;`, the color reverts back to purple. 

Watch the video to see why this is bad.
Blocks: 1347964
Assignee: nobody → gl
Status: NEW → ASSIGNED
Priority: -- → P3
Comment on attachment 8874710 [details]
Bug 1369951 - Use the stored grid highlighter settings for the grid highlighter toggled in the rule view.

https://reviewboard.mozilla.org/r/146084/#review150086

Sweet and simple, I like it.
Adding a new test for this would be awesome!
Attachment #8874710 - Flags: review?(pbrosset)
Summary: "Waffle icon" toggle for the CSS Grid Inspector doesn't remember any state information → Use the stored grid highlighter settings for the grid highlighter toggled in the rule view
Comment on attachment 8874710 [details]
Bug 1369951 - Use the stored grid highlighter settings for the grid highlighter toggled in the rule view.

https://reviewboard.mozilla.org/r/146084/#review150586

Thanks for these tests!
Attachment #8874710 - Flags: review?(pbrosset) → review+
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6fa514595f1b
Use the stored grid highlighter settings for the grid highlighter toggled in the rule view. r=pbro
https://hg.mozilla.org/mozilla-central/rev/6fa514595f1b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
It seems like this (or maybe something else) caused a regression bug. Now when I refresh the page, the color palette reverts back to purple. All the time. Instead of having the colors remembered from everyplace, now it's forgotten from everyplace. Hm.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Jen Simmons [:jensimmons] from comment #7)
> It seems like this (or maybe something else) caused a regression bug. Now
> when I refresh the page, the color palette reverts back to purple. All the
> time. Instead of having the colors remembered from everyplace, now it's
> forgotten from everyplace. Hm.

Hi Jen,

I have filed a new bug (Bug 1374329) for this. I could be wrong, but I don't think we ever persisted the color palettes.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.