Closed Bug 1369977 Opened 3 years ago Closed 3 years ago

Port Bug 1180921 [ Implement pattern-based whitelisting mechanism for cross-origin XHR] to SeaMonkey Installer

Categories

(SeaMonkey :: Installer, enhancement)

SeaMonkey 2.45 Branch
enhancement
Not set
normal

Tracking

(seamonkey2.48 fixed, seamonkey2.49esr fixed, seamonkey2.50 wontfix, seamonkey2.51 fixed, seamonkey2.52 fixed)

RESOLVED FIXED
seamonkey2.52
Tracking Status
seamonkey2.48 --- fixed
seamonkey2.49esr --- fixed
seamonkey2.50 --- wontfix
seamonkey2.51 --- fixed
seamonkey2.52 --- fixed

People

(Reporter: frg, Assigned: frg)

Details

Attachments

(1 file)

Adblock Plus 2.9 is broken in SeaMonkey and Thunderbird. 

When installing the development build I noticed a new error in the log:

> Timestamp: 6/3/2017 10:58:55 AM
> Error: TypeError: Cc['@mozilla.org/addons/policy-service;1'] is 
> undefined
> Source File: resource://gre/modules/ExtensionManagement.jsm
> Line: 144

While it still works we need to add the installer files added in Bug 1180921 to our package-manifest.in. This is also needed for webextensions compatibility. TB and IB already have them in.
[Approval Request Comment]
Regression caused by (bug #): 1180921
User impact if declined: Possible problems with addons which uses webextension services.
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): None. Already broken.
String changes made by this patch: none


Should be taken to 2.48 and 2.29.1esr to avoid any problems with Adblock Plus.
Attachment #8874091 - Flags: review?(iann_bugzilla)
Attachment #8874091 - Flags: approval-comm-release?
Attachment #8874091 - Flags: approval-comm-esr52?
Attachment #8874091 - Flags: approval-comm-beta?
Comment on attachment 8874091 [details] [diff] [review]
1369977-policyservice.patch

r/a=me
Attachment #8874091 - Flags: review?(iann_bugzilla)
Attachment #8874091 - Flags: review+
Attachment #8874091 - Flags: approval-comm-release?
Attachment #8874091 - Flags: approval-comm-release+
Attachment #8874091 - Flags: approval-comm-esr52?
Attachment #8874091 - Flags: approval-comm-esr52+
Attachment #8874091 - Flags: approval-comm-beta?
Attachment #8874091 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.