bilibili.com's user profiles loading failure after Bug 1348390

RESOLVED FIXED

Status

()

Core
DOM
P1
normal
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: YF (Yang), Assigned: shawnjohnjr)

Tracking

({regression})

55 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 verified disabled)

Details

(Reporter)

Description

6 months ago
STR:
Open https://space.bilibili.com/358422/ or other user profile.


Actual results:
All data loading failed. A message box popup.

Error in Web Console:
TypeError: e is undefined  app_6eb88f25.js:10:28831


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2e07ae5b0b69519a59d2943b95534bade9b68758&tochange=8cb64c677091fe3f8ae587e931a5ffe24b997972
(Reporter)

Updated

6 months ago
Blocks: 1348390
Has Regression Range: --- → yes
Has STR: --- → yes

Comment 1

6 months ago
I can reproduce the problem on Win10 Nightly55.
And setting dom.xhr.lowercase_header.enabled=false fixes the problem.
Status: UNCONFIRMED → NEW
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox-esr45: --- → unaffected
status-firefox-esr52: --- → unaffected
Ever confirmed: true
Keywords: regression
Shawn, putting this on your radar so that we could better determine if we should flip the dom.xhr.lowercase_header.enabled as bug 1348390 comment 23 mentioned.
Flags: needinfo?(shuang)
(Assignee)

Comment 3

6 months ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #2)
> Shawn, putting this on your radar so that we could better determine if we
> should flip the dom.xhr.lowercase_header.enabled as bug 1348390 comment 23
> mentioned.

Yes. I'm aware of these bugs and I will disable lowercase-header.
Flags: needinfo?(shuang)
(Assignee)

Comment 4

6 months ago
Since Safari and Chrome already landed case-insensitive response header name to follow the latest XHR specification.
I think it's better to always check lowercase header names in XHR.getAllResponseHeaders().

See:
https://groups.google.com/a/chromium.org/forum/#!msg/blink-dev/_oxlCPNsrck/_LEAqIZDCAAJ
Assigning to Shawn since he appears to already be working on this. That assignment can obviously end in a WONTFIX, Shawn :)
Assignee: nobody → shuang
Priority: -- → P1
(Assignee)

Updated

6 months ago
Depends on: 1370485
This WFM now in Nightly (even after flipping the pref back to true...?). Can you confirm, YF?
Flags: needinfo?(yfdyh000)
(Reporter)

Comment 7

6 months ago
Yes.

Why not be FIXED? https://developer.mozilla.org/en-US/docs/Mozilla/Bugzilla/What_to_do_and_what_not_to_do_in_Bugzilla#Resolving_bugs_as_FIXED
Flags: needinfo?(yfdyh000)
(Reporter)

Updated

6 months ago
status-firefox55: affected → verified disabled
Sure, we can close as FIXED.

(WFM in my previous comment is just an expression, not a formal bug resolution status)
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.