Closed Bug 1370153 Opened 3 years ago Closed 2 years ago

stylo: Re-enable dom/xul/crashtests/461917-1.xhtml

Categories

(Core :: CSS Parsing and Computation, defect, P4)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: TYLin, Assigned: xidorn)

References

Details

Attachments

(1 file)

I disabled dom/xul/crashtests/461917-1.xhtml in bug 1290276 because it crashes on try, but I cannot reproduce it locally for now. 

Let's re-enabled this crashtest for stylo here.
Priority: -- → P1
Just did a try run with this test re-enabled, it's still crashing, now with this assertion:

thread '<unnamed>' panicked at 'Resolving style on element without current styles', /home/worker/workspace/build/src/servo/ports/geckolib/glue.rs:2806

https://treeherder.mozilla.org/#/jobs?repo=try&revision=774847439410cdd32cee715b94b43d38f18014f3&selectedJob=116821222
As of [1] this is the last failing crashtest on stylo. We should fix it!

[1] https://hg.mozilla.org/integration/autoland/rev/91727c7a6f5bb08ea5297e6b82690ece6ca2cd38
Oddly I still can't reproduce this locally, but I do get a few of these assertions:

[Child 1426] WARNING: stylo: requesting a Gecko declaration block?: file /z/moz/d/layout/style/ServoBindings.cpp, line 450
Assignee: nobody → cam
Status: NEW → ASSIGNED
Well, no luck in reproducing this locally, or on the build machine with logs enabled.  It would be nice if there were a way to dynamically turn on RUST_LOG=debug just for a certain test, but it looks like there's no way.  I do have a patch to fix the (unrelated) Gecko declaration block issue.
Priority: P1 → --
I guess it's something funny with how the <tabs> or <wizards> XBL bindings work.  Since they can't be used in regular content documents, it's not high priority.
Assignee: cam → nobody
Blocks: stylo-chrome
No longer blocks: stylo
Status: ASSIGNED → NEW
Priority: -- → P4
Doesn't seem to crash anymore: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ace451fcdd16e3024de294aeb6c6d6f824deb5dc

We can probably just enable it now.
Comment on attachment 8922715 [details]
Bug 1370153 - Re-enable dom/xul/crashtests/461917-1.xhtml.

https://reviewboard.mozilla.org/r/193886/#review198958
Attachment #8922715 - Flags: review+
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b6b2536fa997
Re-enable dom/xul/crashtests/461917-1.xhtml. r=xidorn
https://hg.mozilla.org/mozilla-central/rev/b6b2536fa997
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Assignee: nobody → xidorn+moz
You need to log in before you can comment on or make changes to this bug.