Long URLs that wrap in description do not get linked properly

RESOLVED DUPLICATE of bug 11901

Status

()

Bugzilla
Bugzilla-General
RESOLVED DUPLICATE of bug 11901
16 years ago
5 years ago

People

(Reporter: Steve Lamm, Assigned: justdave)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
If someone enters a long URL has a hyphen in the description, then browsers 
will often wrap the url.

Attached is a patch to keep matching if a url ends with /-$/;
(Reporter)

Comment 1

16 years ago
Created attachment 78813 [details] [diff] [review]
Match URLs that wrap with a hyphen
(Reporter)

Comment 2

16 years ago
The patch does have the side effect that it leaves the newline in the matched 
text, but browsers seem to deal with that ok (checked IE 5.5, Mozilla 
0.999999999, and FreeBSD Netscape 4.x).
Myk, is this still an issue?
I don't know, Matty, I've never seen this bug.  I imagine that it is still an
issue if the bug is new and the patch hasn't been checked in.
(Reporter)

Comment 5

16 years ago
Here is an example,

http://google.yahoo.com/bin/query?p=duper+long+url+that+goes-+on-
+and+on+with+a+hyphen+%28or+two%29+in+it

I used IE to paste the above URL. Unfortunately, I found that IE breaks
URLs on characters besides hyphens, so my patch is insufficient.

http://google.yahoo.com/bin/query?
p=like+a+really+super+duper+long+url+that+goes+on-+and+on+with+a+hyphen+%
28or+two%29+in+it+somewhere-+will+cause+problems+with+some+browsers&hc=0&hs=0

Comment 6

16 years ago
I would like to see this bug fixed.

Comment 7

15 years ago
In a discussion over long URL's and the handling of these in news clients, I
came on following information in rfc2396 round page 33,34

  | In some cases, extra whitespace (spaces, linebreaks, tabs, etc.) may
  | need to be added to break long URI across lines. The whitespace
  | should be ignored when extracting the URI.

somewhat lower

  | Using <> angle brackets around each URI is especially recommended as
  | a delimiting style for URI that contain whitespace.

So I understand, that long URL's may be broken and provided they are between
angle brackets a news client like Mozilla should pick up the URL correctly. 

It seems that Mozilla isn't complying with the RFC.

Can it be fixed?

Bernard
> So I understand, that long URL's may be broken and provided they are between
> angle brackets a news client like Mozilla should pick up the URL correctly. 
> 
> It seems that Mozilla isn't complying with the RFC.

Mozilla, or Bugzilla?

This is a bug against Bugzilla for URLs in bug report comments.  If you want
this fixed in Mozilla you'll need to find or file a suitable bug in the MailNews
product.

Comment 9

14 years ago
This is actually part of bug 11901 which is the root of this problem.  The fix
needs to be server-side and not break URLs in the middle. See the long and
arduous debate there.



*** This bug has been marked as a duplicate of 11901 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.