Closed Bug 1370165 Opened 3 years ago Closed 3 months ago

20:18:13 ERROR - shutil error: Destination path '/builds/slave/test/build/application/Nightly.app/Contents/Resources/gmp-clearkey' already exists

Categories

(Core :: Audio/Video: GMP, defect, P4)

55 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- fixed
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: aryx, Assigned: egao)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=104420144&repo=autoland

20:24:05     INFO -  TEST-START | MozPromise.MoveOnlyType
20:24:05     INFO -  TEST-PASS | MozPromise.MoveOnlyType | test completed (time: 5ms)
20:24:05     INFO -  TEST-START | MozPromise.HeterogeneousChaining
20:24:05     INFO -  mozcrash INFO | Downloading symbols from: https://queue.taskcluster.net/v1/task/HjP2_057TxuTMDOrdDnJCg/artifacts/public/build/target.crashreporter-symbols.zip
20:24:06     INFO -  gtest ERROR | HTTP Error 404: Not Found
Re-classifying this, it appears to be an issue with GMP.
Rank: 35
Component: Audio/Video → Audio/Video: GMP
Priority: -- → P3
Summary: Intermittent Downloading symbols from: https://queue.taskcluster.net/v1/task/HjP2_057TxuTMDOrdDnJCg/artifacts/public/build/target.crashreporter-symbols.zip 20:24:06 followed by gtest ERROR | HTTP Error 404: Not Found → 20:18:13 ERROR - shutil error: Destination path '/builds/slave/test/build/application/Nightly.app/Contents/Resources/gmp-clearkey' already exists
Mass change P3->P4 to align with new Mozilla triage process.
Priority: P3 → P4
Duplicate of this bug: 1539298
Blocks: 1530474

The triage owner has not taken any action so I have submitted a patch to demote the error to a warning, which is what I feel this message should be. The fact that file already exists should not be considered an error worth reporting.

Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dedacb18f710
demote shutil copy error to a warning r=jmaher
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.