Closed Bug 1370400 Opened 3 years ago Closed 3 years ago

Assertion failure: mOnStartRequestCalled (OnStartRequest should be called before OnStopRequest)

Categories

(Core :: Networking: Cache, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: michal, Assigned: michal)

References

(Blocks 1 open bug)

Details

mozilla::net::nsHttpChannel::OnStopRequest (this=0xbd9df000, request=0xbd580200, ctxt=0x0, status=nsresult::NS_OK)
    at /opt/moz/hg-inbound-2/netwerk/protocol/http/nsHttpChannel.cpp:7385
7385	        MOZ_ASSERT(mOnStartRequestCalled,
(rr) p mOnStartRequestCalled
$1 = false
(rr) bt 10
#0  0xffffffff in mozilla::net::nsHttpChannel::OnStopRequest(nsIRequest*, nsISupports*, nsresult) (this=0xbd9df000, request=0xbd580200, ctxt=0x0, status=nsresult::NS_OK) at /opt/moz/hg-inbound-2/netwerk/protocol/http/nsHttpChannel.cpp:7385
#1  0xffffffff in nsInputStreamPump::OnStateStop() (this=0xbd580200) at /opt/moz/hg-inbound-2/netwerk/base/nsInputStreamPump.cpp:734
#2  0xffffffff in nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) (this=0xbd580200, stream=0xbd541ba0)
    at /opt/moz/hg-inbound-2/netwerk/base/nsInputStreamPump.cpp:448
#3  0xffffffff in nsInputStreamReadyEvent::Run() (this=0xbd57d280) at /opt/moz/hg-inbound-2/xpcom/io/nsStreamUtils.cpp:96
#4  0xffffffff in nsThread::ProcessNextEvent(bool, bool*) (this=0xf3403140, aMayWait=false, aResult=0xfffeb06f)
    at /opt/moz/hg-inbound-2/xpcom/threads/nsThread.cpp:1322
#5  0xffffffff in NS_ProcessNextEvent(nsIThread*, bool) (aThread=0xf3403140, aMayWait=false)
    at /opt/moz/hg-inbound-2/xpcom/threads/nsThreadUtils.cpp:472
#6  0xffffffff in mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) (this=0xf34022e0, aDelegate=0xf7029440)
    at /opt/moz/hg-inbound-2/ipc/glue/MessagePump.cpp:96
#7  0xffffffff in MessageLoop::RunInternal() (this=0xf7029440) at /opt/moz/hg-inbound-2/ipc/chromium/src/base/message_loop.cc:238
#8  0xffffffff in MessageLoop::Run() (this=0xf7029440) at /opt/moz/hg-inbound-2/ipc/chromium/src/base/message_loop.cc:231
#9  0xffffffff in MessageLoop::Run() (this=0xf7029440) at /opt/moz/hg-inbound-2/ipc/chromium/src/base/message_loop.cc:211
#10 0xffffffff in nsBaseAppShell::Run() (this=0xe7164a10) at /opt/moz/hg-inbound-2/widget/nsBaseAppShell.cpp:156
This seems to be caused by the mistake in patch v1 in bug 1367742. mTransactionPump was not suspended and nsHttpChannel::OnStopRequest was called before nsHttpChannel::ContinueProcessResponse3.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.