OnChange event in combobox won't fire if combobox is closed

RESOLVED DUPLICATE of bug 126379

Status

Mozilla Localizations Graveyard
MozillaTranslator
RESOLVED DUPLICATE of bug 126379
15 years ago
4 years ago

People

(Reporter: Matthias, Assigned: John Keiser (jkeiser))

Tracking

Details

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

If the combobox has the focus and is closed you can scroll from one entry to an
other, but the OnChange event is not fired.

Reproducible: Always
Steps to Reproduce:
1. Click in combobox
2. CLick in combobox to close it (now it has the focus)
3. Use keyport arrow-keys to scroll in closed combobox from one entry to an other

Actual Results:  Nothing

Expected Results:  the OnChange event should be fired

<html>
<head>
<script language="JavaScript">
function UpdateInfo(select)
{ document.new_form.prj_info.value="ProjektNr.: " +
select.value.substring(0,select.value.indexOf('@')) + ", " +
select.value.substring(select.value.indexOf('@')+1,select.value.length)
  return true;
}
//-->
</script>
</head>
<body>
<form id="new_form" name="new_form">
<select id="new_prj" name="new_prj" tabindex="1" size="1"  onchange="return
UpdateInfo(this);">
<option value="1234@entry 1">1234</option>
<option value="5678@entry 2">5678</option>
<option value="9012@entry 3">9012</option>
</select><br>
<input id="prj_info" name="prj_info" value="ProjektNr.: 1234, entry 1" size="90"
style="border: none;" readonly>
</form></body>
</html>

Updated

15 years ago
QA Contact: madhur → tpreston

Comment 1

15 years ago
confirmed on build 20020422 on Windows 2000 as well as 98
Status: UNCONFIRMED → NEW
Component: HTML Form Controls → MozillaTranslator
Ever confirmed: true

Comment 2

15 years ago
-->
Assignee: rods → jkeiser
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 3

15 years ago
My observed behavior: it fires, but only when you tab out.  This is as designed,
a compromise between pages that use it for navigation and those that use it for
data integrity; when you finish changing the combobox if fires, and not until then.

If this is not firing for you *ever*, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Target Milestone: mozilla1.0 → ---

Updated

15 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 4

15 years ago
This is a duplicate of bug 126379.

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
The MozillaTranslator component is moving to the Mozilla Localisations product.
Product: Browser → Mozilla Localizations
Version: other → unspecified
Product: Mozilla Localizations → Mozilla Localizations Graveyard
You need to log in before you can comment on or make changes to this bug.