Crash in mozilla::gl::AndroidNativeWindow::~AndroidNativeWindow

RESOLVED WONTFIX

Status

()

Firefox for Android
Toolbar
P3
critical
RESOLVED WONTFIX
11 months ago
8 months ago

People

(Reporter: ting, Unassigned)

Tracking

({crash, regression, topcrash})

55 Branch
ARM
Android
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(firefox53 unaffected, firefox54 unaffected, firefox55+ wontfix, firefox56 wontfix)

Details

(crash signature)

(Reporter)

Description

11 months ago
This bug was filed from the Socorro interface and is 
report bp-e1d49ee3-f1ac-4a5a-82cd-ba1770170604.
=============================================================
Top #4 of Nightly 20170604100226 on Android, 5 reports from a single installation. But there're 25 reports from 13 installations in the past week.
(Reporter)

Comment 1

11 months ago
Any ideas?
Flags: needinfo?(snorp)
Crashing in plugin stuff, so not exactly a high priority, but I'll try to take a look. I don't see an immediate cause for the crash. We guard against trying to destroy a null ANativeWindow, so it must be garbage or in some other bad state.
Flags: needinfo?(snorp)
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox55: --- → affected
Keywords: regression
Priority: -- → P3
Hardware: Unspecified → ARM
Version: unspecified → 55 Branch
Buildid         Count
20170530180455  1
20170531100238  18
20170602100159  2
20170604100226  5
20170606100206  1

So it's from something that landed near the end of May.
:snorp, I made it fix-optional for 55, please change it back if you think we should make sure we fix it in 55.
status-firefox55: affected → fix-optional
status-firefox56: --- → affected
Flags: needinfo?(snorp)
Flags: needinfo?(snorp)
Duplicate of this bug: 1373916
The signature "mozilla::gl::AndroidNativeWindow::~AndroidNativeWindow" is ranked #2 and "@0x0 | mozilla::gl::AndroidNativeWindow::~AndroidNativeWindow" is ranked #3 in beta top-crashers.
Keywords: topcrash
Looks like it is skipping, can you help James?
status-firefox55: fix-optional → affected
Flags: needinfo?(snorp)
Crash Signature: [@ mozilla::gl::AndroidNativeWindow::~AndroidNativeWindow] → [@ mozilla::gl::AndroidNativeWindow::~AndroidNativeWindow] [@ 0x0 | mozilla::gl::AndroidNativeWindow::~AndroidNativeWindow]
In summing the numbers for the 2 signatures, it's ranked #1 in FennecAndroid top-crashers.
Flags: needinfo?(milan)
Jamie, is this something you can help accelerate.
Flags: needinfo?(milan) → needinfo?(jnicol)
We are going to build a fennec 55.0.2 next Monday or Tuesday.
Would be great if we could have a fix for this crash.
thanks
tracking-firefox55: --- → blocking
These are all from Flash users, which we've killed in 56. Fewer than 1% of them use Flash, so I don't think it's really worth fixing in 55. #1 crash is pretty interesting, regardless! It must be crashing a lot for those people. We could probably flip the pref to turn Flash off by default, but I am not sure that would really help, as they've already explicitly chosen to install Flash via pretty unorthodox means. They'll probably just turn it back on.
Flags: needinfo?(snorp)
You mean that flash is not the future anymore ?  ;)
OK, I won't cry about that!

For my culture, you found that where?  "Flash™ Version" here ?
https://crash-stats.mozilla.com/signature/?signature=mozilla%3A%3Agl%3A%3AAndroidNativeWindow%3A%3A~AndroidNativeWindow&date=%3E%3D2017-08-04T19%3A07%3A00.000Z&date=%3C2017-08-11T19%3A07%3A00.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-date&page=1#summary
status-firefox55: affected → wontfix
status-firefox56: affected → wontfix
tracking-firefox55: blocking → +
This sounds like a wontfix based on the last few comments. Dropping needinfo as it is not needed any more.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(jnicol)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.