Closed Bug 1370753 Opened 2 years ago Closed 2 years ago

Google API key missing from official Firefox (release and beta) for Android

Categories

(Firefox Build System :: Android Studio and Gradle Integration, enhancement)

enhancement
Not set

Tracking

(firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: francois, Assigned: gcp)

References

(Blocks 1 open bug)

Details

(Whiteboard: #sbv4-m10 [google-api-safe-browsing])

Attachments

(2 files)

If we go into about:support on Fennec Beta (downloaded from Google Play), it shows that the Google API key is missing.

This is going to prevent Safe Browsing updates from working.
Blocks: 1303393
See Also: → 1374268
Whiteboard: #sbv4-m8
(In reply to François Marier [:francois] from comment #0)
> If we go into about:support on Fennec Beta (downloaded from Google Play), it
> shows that the Google API key is missing.
> 
> This is going to prevent Safe Browsing updates from working.

It doesn't look like we ever set a Google API key on Android, based on http://searchfox.org/mozilla-central/search?q=google-api&path=.  Is this a new requirement?

In any case, this looks like Build Config.
Component: General → Build Config & IDE Support
(In reply to Nick Alexander :nalexander from comment #1)
> It doesn't look like we ever set a Google API key on Android, based on
> http://searchfox.org/mozilla-central/search?q=google-api&path=.  Is this a
> new requirement?

I suspect that the Safe Browsing V2 servers didn't require the API key for all of the lists we use, version 4 will require a valid API key though.
Whiteboard: #sbv4-m8 → #sbv4-m9
Summary: Google API key missing from official Firefox Beta for Android → Google API key missing from official Firefox (release and beta) for Android
GCP, I was told by snorp that you might know how to add the Google API key to the Fennec build config. Is that true?
Flags: needinfo?(gpascutto)
Blocks: 1377976
No longer blocks: safebrowsingv4
(In reply to François Marier [:francois] from comment #3)
> GCP, I was told by snorp that you might know how to add the Google API key
> to the Fennec build config. Is that true?

No, you probably have to ask a build peer or something?
Flags: needinfo?(gpascutto)
Or is it just a matter of updates the mozconfigs, i.e. is it already automatically put in /builds/gapi.data?
Comment on attachment 8884853 [details]
Bug 1370753 - Add Google API key to Android builds.

https://reviewboard.mozilla.org/r/155728/#review161110
Attachment #8884853 - Flags: review?(mh+mozilla) → review+
Pushed by gpascutto@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2bec8580742b
Add Google API key to Android builds. r=glandium
https://hg.mozilla.org/mozilla-central/rev/2bec8580742b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Backed out for breaking Android L10n nightlies:

https://hg.mozilla.org/mozilla-central/rev/400584289c8fa44060d6443a3288ef57cf73ff4e

Push with failing Android L10n nightlies: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=67cd1ee26f2661fa5efe3d952485ab3c89af4271&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=114309099&repo=mozilla-central

[task 2017-07-14T11:03:00.395358Z] 11:03:00     INFO -  checking for the Mozilla API key... no
[task 2017-07-14T11:03:00.395660Z] 11:03:00     INFO -  checking for the Google API key... no
[task 2017-07-14T11:03:00.395911Z] 11:03:00     INFO -  ERROR: '/builds/gapi.data': No such file or directory.
[task 2017-07-14T11:03:00.425448Z] 11:03:00     INFO -  *** Fix above errors and then restart with\
[task 2017-07-14T11:03:00.425629Z] 11:03:00     INFO -                 "make -f client.mk build"
[task 2017-07-14T11:03:00.425773Z] 11:03:00     INFO -  client.mk:379: recipe for target 'configure' failed
[task 2017-07-14T11:03:00.425907Z] 11:03:00     INFO -  make: *** [configure] Error 1
Status: RESOLVED → REOPENED
Flags: needinfo?(gpascutto)
Resolution: FIXED → ---
Assignee: nobody → gpascutto
Target Milestone: Firefox 56 → ---
l10n slaves have no builds keys, this needs a tweak to:
https://dxr.mozilla.org/mozilla-central/source/mobile/android/config/mozconfigs/android-api-15/l10n-nightly

to overrule the default.
Flags: needinfo?(gpascutto)
aarch, too, https://dxr.mozilla.org/mozilla-central/search?q=without-mozilla-api&redirect=false lists the current ones.

Also, I triggered the tc(L10n) build on the try run of the original patch, and those reproduce the error we've seen on nightly. Which is nice, so we can test the fix on try.
Blocks: 1384326
MozReview-Commit-ID: KDgbZr7ygpk
Attachment #8890334 - Flags: review?(mh+mozilla)
Attachment #8890334 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/13750b02d021
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Duplicate of this bug: 1384326
Whiteboard: #sbv4-m9 → #sbv4-m10
Whiteboard: #sbv4-m10 → #sbv4-m10 [google-api-safe-browsing]
Blocks: 1394017
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 56 → mozilla56
You need to log in before you can comment on or make changes to this bug.