<input type=date> datepicker doesn't fire change event

RESOLVED FIXED in Firefox 56

Status

()

P3
normal
RESOLVED FIXED
a year ago
6 months ago

People

(Reporter: jeroen.pulles, Assigned: jessica)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
mozilla56
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8875264 [details]
datepicker.html

The new datepicker widget for <input type=date> doesn't fire change events. 

I expected to get change events when I click on a date in the picker panel,

and I expect to get change events when typing a date in the text field and then blurring the input. 

The value property of the input does show the edited value when polled (see attached example).

I'm running Firefox Nightly: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0
Blocks: 1323674
Priority: -- → P3
(Assignee)

Comment 1

a year ago
Works on <input type="time">, let me see what's going on.
Assignee: nobody → jjong
(Assignee)

Comment 2

a year ago
NS_FORM_INPUT_DATE missing in HTMLInputElement::MayFireChangeOnBlur() [1], fixing it now.


[1] http://searchfox.org/mozilla-central/rev/d840ebd5858a61dbc1622487c1fab74ecf235e03/dom/html/HTMLInputElement.h#1612-1617
(Assignee)

Comment 3

a year ago
Created attachment 8876647 [details] [diff] [review]
patch, v1.

Hi Olli, details are in the patch comment.
I've added tests only for changing value from the keyboard, since we do not have a way for testing picker yet.
Attachment #8876647 - Flags: review?(bugs)

Updated

a year ago
Attachment #8876647 - Flags: review?(bugs) → review+
(Assignee)

Comment 4

a year ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e7b28fe42f9109b912eb4c53c55f53fef3d7be82&group_state=expanded

There some failures but seems not related to this patch.
Keywords: checkin-needed

Comment 5

a year ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/20882c387b4e
Fire change/input events after selecting a date/time from picker. r=smaug
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/20882c387b4e
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56

Comment 7

6 months ago
on removing the value in an input of type date by clicking the (x) will not yet fire the change-event

v59.0.2 &
v60.0b11 Developer

Comment 8

6 months ago
I´ll disable my account, because i don´t want to publish my mail for other users/bots, very disappointing. hope the comment remains.

Updated

6 months ago
Depends on: 1454095
You need to log in before you can comment on or make changes to this bug.