Closed Bug 1370893 Opened 3 years ago Closed 3 years ago

Deprecate the TLS compression feature in all TLS versions

Categories

(NSS :: Libraries, enhancement)

3.31
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: KaiE, Assigned: ekr)

References

Details

Attachments

(1 file)

44 bytes, text/x-phabricator-request
ttaubert
: review+
Details | Review
It has been suggested that NSS shall disable support for TLS compression in all TLS versions, in TLS 1.2 and older.

We could start by making it impossible to enable TLS compression in a future NSS release.

(However, it would be good to keep the TLS compression code alive in the NSS code base for another while, to ensure NSS consumers could patch NSS to re-enable it, it necessary.)
Attachment #8904242 - Flags: review+
Keywords: checkin-needed
Assignee: nobody → ekr
Target Milestone: --- → 3.33
Landed at: https://hg.mozilla.org/projects/nss/rev/d7c1635da930
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Thanks Eric!
Keywords: checkin-needed
Attachment #8904242 - Flags: review+
See Also: → 1409587
You need to log in before you can comment on or make changes to this bug.