Closed Bug 1370987 Opened 3 years ago Closed 2 years ago

firefox build issue when using MINGW32 windows 7 + VS 2015

Categories

(Firefox Build System :: General, defect)

55 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: muthuraj90ec, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

./mach build


Actual results:

 7:28.00 c:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\BIN\amd64_x86\cl
.exe -P -Fiself-hosting-preprocessed.pp -utf-8 -DMOZ_PERMISSIONS=1 -DEXPOSE_INTL
_API=1 -D_WIN32_WINNT=0x601 -DMOZ_CONTENT_SANDBOX=1 -DMOZ_ALLOW_LEGACY_EXTENSION
S=1 -DU_USING_ICU_NAMESPACE=0 -DNO_NSPR_10_SUPPORT=1 -DMOZ_B2G_VERSION="1.0.0" -
DMOZ_SERVICES_HEALTHREPORT=1 -DHAVE_STDINT_H=1 -DMOZ_PHOTON_THEME=1 -DMOZ_XUL=1
-DUSE_SKIA=1 -DMALLOC_H=<malloc.h> -DMOZ_MACBUNDLE_ID=org.mozilla.nightlydebug -
DSTDC_HEADERS=1 -DMOZ_RUST_URLPARSE=1 -DWIN32_LEAN_AND_MEAN=1 -DMOZ_PEERCONNECTI
ON=1 -DSTATIC_JS_API=1 -DMOZ_DEBUG_RUST=1 -DMOZ_USER_DIR="Mozilla" -DMOZ_DUMP_PA
INTING=1 -DMOZ_REPLACE_MALLOC=1 -DHAVE_MALLOC_H=1 -DWINVER=0x601 -DNS_PRINT_PREV
IEW=1 -DMOZ_LIBAV_FFT=1 -DMOZ_TREE_PIXMAN=1 -DMOZ_DLL_SUFFIX=".dll" -DNS_PRINTIN
G=1 -DMOZ_MEMORY=1 -DX_DISPLAY_MISSING=1 -DMOZ_MAINTENANCE_SERVICE=1 -DMOZ_WEBSP
EECH=1 -DCROSS_COMPILE= -DNS_ENABLE_TSF=1 -DMOZ_ENABLE_MASK_AS_SHORTHAND=1 -DMOZ
ILLA_UAVERSION="55.0" -DMOZ_FMP4=1 -DMOZ_REFLOW_PERF_DSP=1 -DMOZ_APP_UA_NAME=""
-D_X86_=1 -DMOZ_WEBM_ENCODER=1 -DMOZ_APP_UA_VERSION="55.0a1" -DMOZ_TREE_CAIRO=1
-DMOZ_ADDON_SIGNING=1 -DMSVC_HAS_DIA_SDK=1 -DENABLE_INTL_API=1 -DMOZ_CRASHREPORT
ER_ENABLE_PERCENT=100 -DWIN32=1 -DVPX_X86_ASM=1 -DDEBUG=1 -DHAVE_LOCALECONV=1 -D
MOZ_STATIC_JS=1 -DMOZ_LOGGING=1 -DMOZILLA_VERSION_U=55.0a1 -D_CRT_SECURE_NO_WARN
INGS=1 -DMOZ_RAW=1 -DMOZ_WEBSPEECH_TEST_BACKEND=1 -DMOZ_ENABLE_SKIA_PDF=1 -DMOZ_
WEBRTC_ASSERT_ALWAYS=1 -DMOZ_BUILD_APP=browser -DMOZ_CRASHREPORTER=1 -DMOZ_ENABL
E_SIGNMAR=1 -DMOZ_MSVC_STL_WRAP_RAISE=1 -DMOZ_PHOTON_ANIMATIONS=1 -DMOZ_PHOENIX=
1 -DHAVE_ISATTY=1 -DHAVE_FORCEINLINE=1 -DMOZILLA_VERSION="55.0a1" -DMOZ_WMF=1 -D
NIGHTLY_BUILD=1 -DHAVE_INTTYPES_H=1 -DMOZ_SRTP=1 -DMOZ_WEBRTC_SIGNALING=1 -DEARL
Y_BETA_OR_EARLIER=1 -DMOZ_ENABLE_SKIA_PDF_SFNTLY=1 -DMOZ_VORBIS=1 -DE10S_TESTING
_ONLY=1 -DGTEST_HAS_RTTI=0 -DNOMINMAX=1 -D_CRT_NONSTDC_NO_WARNINGS=1 -DD_INO=d_i
no -DMOZ_B2G_OS_NAME="" -DTARGET_XPCOM_ABI="x86-msvc" -DMOZ_SECUREELEMENT=1 -D_W
IN32_IE=0x0800 -DFIREFOX_VERSION=55.0a1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DM
OZ_DISTRIBUTION_ID="org.mozilla" -DMOZ_UPDATER=1 -DXP_WIN=1 -DFORCE_PR_LOG=1 -DM
OZ_SAMPLE_TYPE_FLOAT32=1 -D_WINDOWS=1 -DMOZ_MEMORY_WINDOWS=1 -DMOZ_PLACES=1 -DMO
Z_CRASHREPORTER_INJECTOR=1 -DA11Y_LOG=1 -DMOZ_VPX_NO_MEM_REPORTING=1 -DMOZ_BUILD
_WEBRENDER=1 -DBUILD_CTYPES=1 -DMOZ_GMP_SANDBOX=1 -DMOZ_ENABLE_SKIA=1 -DMOZ_DATA
_REPORTING=1 -DMOZ_GECKO_PROFILER=1 -DMOZ_VTUNE=1 -DMOZ_SANDBOX=1 -D_USE_MATH_DE
FINES=1 -DUSE_SKIA_GPU=1 -DMOZ_FEEDS=1 -DHAVE_UINT64_T=1 -DXP_WIN32=1 -DMOZ_BUND
LED_FONTS=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DENABLE_SYSTEM_EXTENSION_DIRS=1 -DMOZ
_FFVPX=1 -DENABLE_TESTS=1 -DHAVE_SEH_EXCEPTIONS=1 -DMOZ_UPDATE_CHANNEL=default -
DMOZ_SCTP=1 -DMOZ_WEBRTC=1 -DHAVE_IO_H=1 -DMOZ_PROFILING=1 -DMOZ_REFLOW_PERF=1 -
DU_STATIC_IMPLEMENTATION=1 -DMALLOC_USABLE_SIZE_CONST_PTR=const self-hosting-cpp
-input.cpp
 7:29.39 certdata.c
 7:29.87 fxc -nologo -Tvs_4_0_level_9_3 s:/firefoxclone/mozilla-central/gfx/laye
rs/d3d11\CompositorD3D11.hlsl -ELayerQuadVS -VnLayerQuadVS -Vi -DVERTEX_SHADER -
Fhc:\users\rramalin\appdata\local\temp\tmp5rn2mf
 7:29.88 Traceback (most recent call last):
 7:29.88   File "c:\mozilla-build\python\Lib\runpy.py", line 162, in _run_module
_as_main
 7:29.88     "__main__", fname, loader, pkg_name)
 7:29.88   File "c:\mozilla-build\python\Lib\runpy.py", line 72, in _run_code
 7:29.89     exec code in run_globals
 7:29.89   File "s:\firefoxclone\mozilla-central\python\mozbuild\mozbuild\action
\file_generate.py", line 108, in <module>
 7:29.89     sys.exit(main(sys.argv[1:]))
 7:29.89   File "s:\firefoxclone\mozilla-central\python\mozbuild\mozbuild\action
\file_generate.py", line 63, in main
 7:29.90     ret = module.__dict__[method](output, *args.additional_arguments)
 7:29.90   File "s:/firefoxclone/mozilla-central/gfx/layers/d3d11/genshaders.py"
, line 26, in main
 7:29.90     return process_manifest(output_fp, input_filename)
 7:29.90   File "s:/firefoxclone/mozilla-central/gfx/layers/d3d11/genshaders.py"
, line 63, in process_manifest
 7:29.91     output_fp = output_fp)
 7:29.91   File "s:/firefoxclone/mozilla-central/gfx/layers/d3d11/genshaders.py"
, line 92, in run_fxc
 7:29.91     proc_stdout = subprocess.check_output(argv)
 7:29.91   File "c:\mozilla-build\python\Lib\subprocess.py", line 566, in check_
output
 7:29.92     process = Popen(stdout=PIPE, *popenargs, **kwargs)
 7:29.92   File "c:\mozilla-build\python\Lib\subprocess.py", line 710, in __init
__
 7:29.92     errread, errwrite)
 7:29.92   File "c:\mozilla-build\python\Lib\subprocess.py", line 958, in _execu
te_child
 7:29.93     startupinfo)
 7:29.93 WindowsError: [Error 2] The system cannot find the file specified
 7:29.93 backend.mk:9: recipe for target 'CompositorD3D11Shaders.h' failed
 7:29.93 mozmake.EXE[5]: *** [CompositorD3D11Shaders.h] Error 1
 7:29.94 mozmake.EXE[5]: *** Deleting file 'CompositorD3D11Shaders.h'
 7:29.94 s:/firefoxclone/mozilla-central/config/recurse.mk:100: recipe for targe
t 'gfx/layers/export' failed
 7:29.94 mozmake.EXE[4]: *** [gfx/layers/export] Error 2
 7:29.94 mozmake.EXE[4]: *** Waiting for unfinished jobs....
 7:30.26 Microsoft (R) C/C++ Optimizing Compiler Version 19.00.24215.1 for x86
 7:30.26 Copyright (C) Microsoft Corporation.  All rights reserved.
 7:30.27
 7:30.27 PythonCSSProps.h
 8:20.11 s:/firefoxclone/mozilla-central/config/recurse.mk:32: recipe for target
 'export' failed
 8:20.12 mozmake.EXE[3]: *** [export] Error 2
 8:20.12 s:/firefoxclone/mozilla-central/config/rules.mk:519: recipe for target
'default' failed
 8:20.12 mozmake.EXE[2]: *** [default] Error 2
 8:20.12 s:/firefoxclone/mozilla-central/client.mk:419: recipe for target 'realb
uild' failed
 8:20.12 mozmake.EXE[1]: *** [realbuild] Error 2
 8:20.12 client.mk:170: recipe for target 'build' failed
 8:20.12 mozmake.EXE: *** [build] Error 2
 8:20.17 0 compiler warnings present.
2


Expected results:

Task completed
Component: Untriaged → Build Config
Product: Firefox → Core
bug 1365859 added the invocation of fxc to the build.
Blocks: 1365859
Product: Core → Firefox Build System
Looks like this can be closed due to the work in bug 1365859
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1365859
You need to log in before you can comment on or make changes to this bug.