Closed Bug 1371126 Opened 4 years ago Closed 4 years ago

Intermittent netwerk/test/unit/test_multipart_streamconv-byte-by-byte.js | xpcshell return code: 1

Categories

(Core :: Networking, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1370448

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Duplicate of this bug: 1371172
Duplicate of this bug: 1371167
From the crash log, this appears to be a dup of 1370448, which has been fixed.

01:35:14     INFO -  TEST-PASS | netwerk/test/unit/test_multipart_streamconv-byte-by-byte.js | onStopRequest - [onStopRequest : 85] true == true
01:35:14     INFO -  TEST-PASS | netwerk/test/unit/test_multipart_streamconv-byte-by-byte.js | responseHandler - [responseHandler : 50] "<?xml version='1.0'?><root/>" == "<?xml version='1.0'?><root/>"
01:35:14     INFO -  TEST-PASS | netwerk/test/unit/test_multipart_streamconv-byte-by-byte.js | responseHandler - [responseHandler : 51] "text/xml" == "text/xml"
01:35:14     INFO -  (xpcshell/head.js) | test finished (1)
01:35:14     INFO -  exiting test
01:35:14     INFO -  PID 9760 | ###!!! ERROR: Potential deadlock detected:
01:35:14     INFO -  PID 9760 | === Cyclical dependency starts at
01:35:14     INFO -  PID 9760 | --- Mutex : TimerThread.mMonitor calling context
01:35:14     INFO -  PID 9760 |   [stack trace unavailable]
01:35:14     INFO -  PID 9760 | --- Next dependency:
01:35:14     INFO -  PID 9760 | --- Mutex : nsSocketTransportService::mLock (currently acquired)
01:35:14     INFO -  PID 9760 |  calling context
01:35:14     INFO -  PID 9760 |   [stack trace unavailable]
01:35:14     INFO -  PID 9760 | --- Next dependency:
01:35:14     INFO -  PID 9760 | --- Mutex : nsTimerImpl::mMutex (currently acquired)
01:35:14     INFO -  PID 9760 |  calling context
01:35:14     INFO -  PID 9760 |   [stack trace unavailable]
01:35:14     INFO -  PID 9760 | === Cycle completed at
01:35:14     INFO -  PID 9760 | --- Mutex : TimerThread.mMonitor calling context
01:35:14     INFO -  PID 9760 |   [stack trace unavailable]
01:35:14     INFO -  PID 9760 | Deadlock may happen for some other execution
01:35:14     INFO -  PID 9760 | [9760] ###!!! ASSERTION: Potential deadlock detected:
01:35:14     INFO -  PID 9760 | Cyclical dependency starts at
01:35:14     INFO -  PID 9760 | Mutex : TimerThread.mMonitor
01:35:14     INFO -  PID 9760 | Next dependency:
01:35:14     INFO -  PID 9760 | Mutex : nsSocketTransportService::mLock (currently acquired)
01:35:14     INFO -  PID 9760 | Next dependency:
01:35:14     INFO -  PID 9760 | Mutex : nsTimerImpl::mMutex (currently acquired)
01:35:14     INFO -  PID 9760 | Cycle completed at
01:35:14     INFO -  PID 9760 | Mutex : TimerThread.mMonitor
01:35:14     INFO -  PID 9760 | Deadlock may happen for some other execution
01:35:14     INFO -  PID 9760 | : 'Error', file c:/builds/moz2_slave/autoland-w64-d-000000000000000/build/src/xpcom/threads/BlockingResourceBase.cpp, line 308
01:35:27     INFO -  PID 9760 | #01: mozilla::OffTheBooksMutex::Lock() [xpcom/threads/BlockingResourceBase.cpp:383]
01:35:27     INFO -  PID 9760 | #02: TimerThread::RemoveTimer(nsTimerImpl *) [xpcom/threads/TimerThread.cpp:580]
01:35:27     INFO -  PID 9760 | #03: nsTimerImpl::InitCommon(mozilla::BaseTimeDuration<mozilla::TimeDurationValueCalculator> const &,unsigned int,nsTimerImpl::Callback &&) [xpcom/threads/nsTimerImpl.cpp:224]
01:35:27     INFO -  PID 9760 | #04: nsTimerImpl::InitCommon(unsigned int,unsigned int,nsTimerImpl::Callback &&) [xpcom/threads/nsTimerImpl.cpp:205]
01:35:27     INFO -  PID 9760 | #05: nsTimerImpl::Init(nsIObserver *,unsigned int,unsigned int) [xpcom/threads/nsTimerImpl.cpp:328]
01:35:27     INFO -  PID 9760 | #06: <lambda_5a2b5c6d24e46eeba8c7c381d7cd37fb>::operator() [netwerk/base/nsSocketTransportService2.cpp:1629]
01:35:27     INFO -  PID 9760 | #07: mozilla::detail::RunnableFunction<<lambda_5a2b5c6d24e46eeba8c7c381d7cd37fb> >::Run() [obj-firefox/dist/include/nsThreadUtils.h:461]
01:35:27     INFO -  PID 9760 | #08: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:1370]
01:35:27     INFO -  PID 9760 | #09: NS_ProcessNextEvent(nsIThread *,bool) [xpcom/threads/nsThreadUtils.cpp:472]
01:35:27     INFO -  PID 9760 | #10: mozilla::SpinEventLoopUntil<1,<lambda_56960601ff793302007fcdece32fa3b7> >(<lambda_56960601ff793302007fcdece32fa3b7> &&,nsIThread *) [xpcom/threads/nsThreadUtils.h:286]
01:35:27     INFO -  PID 9760 | #11: nsThread::Shutdown() [xpcom/threads/nsThread.cpp:1036]
01:35:27     INFO -  PID 9760 | #12: mozilla::net::WaitForThreadShutdown::Run() [netwerk/base/nsPACMan.cpp:159]
01:35:27     INFO -  PID 9760 | #13: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:1370]
01:35:27     INFO -  PID 9760 | #14: NS_ProcessNextEvent(nsIThread *,bool) [xpcom/threads/nsThreadUtils.cpp:472]
01:35:27     INFO -  PID 9760 | #15: mozilla::SpinEventLoopUntil<1,<lambda_ba23c3a8cdf222e68bd8d404642209b6> >(<lambda_ba23c3a8cdf222e68bd8d404642209b6> &&,nsIThread *) [obj-firefox/dist/include/nsThreadUtils.h:286]
01:35:27     INFO -  PID 9760 | #16: mozilla::net::nsHttpConnectionMgr::Shutdown() [netwerk/protocol/http/nsHttpConnectionMgr.cpp:245]
01:35:27     INFO -  PID 9760 | #17: mozilla::net::nsHttpHandler::ShutdownConnectionManager() [netwerk/protocol/http/nsHttpHandler.cpp:2622]
01:35:27     INFO -  PID 9760 | #18: mozilla::net::nsHttpHandler::Observe(nsISupports *,char const *,char16_t const *) [netwerk/protocol/http/nsHttpHandler.cpp:2241]
01:35:27     INFO -  PID 9760 | #19: nsObserverList::NotifyObservers(nsISupports *,char const *,char16_t const *) [xpcom/ds/nsObserverList.cpp:112]
01:35:27     INFO -  PID 9760 | #20: nsObserverService::NotifyObservers(nsISupports *,char const *,char16_t const *) [xpcom/ds/nsObserverService.cpp:285]
01:35:27     INFO -  PID 9760 | #21: mozilla::ShutdownXPCOM(nsIServiceManager *) [xpcom/build/XPCOMInit.cpp:882]
01:35:27     INFO -  PID 9760 | #22: XRE_XPCShellMain(int,char * *,char * *,XREShellData const *) [js/xpconnect/src/XPCShellImpl.cpp:1550]
01:35:27     INFO -  PID 9760 | #23: NS_internal_main(int,char * *,char * *) [js/xpconnect/shell/xpcshell.cpp:68]
01:35:27     INFO -  PID 9760 | #24: wmain [toolkit/xre/nsWindowsWMain.cpp:118]
01:35:27     INFO -  PID 9760 | #25: __scrt_common_main_seh [f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:253]
01:35:27     INFO -  PID 9760 | #26: KERNEL32.DLL + 0x167e
01:35:27     INFO -  PID 9760 | #27: ntdll.dll + 0x1c3f1
01:35:27     INFO -  PID 9760 | [9760] ###!!! ASSERTION: Potential deadlock detected:
01:35:27     INFO -  PID 9760 | Cyclical dependency starts at
01:35:27     INFO -  PID 9760 | Mutex : TimerThread.mMonitor
01:35:27     INFO -  PID 9760 | Next dependency:
01:35:27     INFO -  PID 9760 | Mutex : nsSocketTransportService::mLock (currently acquired)
01:35:27     INFO -  PID 9760 | Next dependency:
01:35:27     INFO -  PID 9760 | Mutex : nsTimerImpl::mMutex (currently acquired)
01:35:27     INFO -  PID 9760 | Cycle completed at
01:35:27     INFO -  PID 9760 | Mutex : TimerThread.mMonitor
01:35:27     INFO -  PID 9760 | Deadlock may happen for some other execution
01:35:27     INFO -  PID 9760 | : 'Error', file c:/builds/moz2_slave/autoland-w64-d-000000000000000/build/src/xpcom/threads/BlockingResourceBase.cpp, line 308
01:35:27     INFO -  PID 9760 | Hit MOZ_CRASH() at c:/builds/moz2_slave/autoland-w64-d-000000000000000/build/src/memory/mozalloc/mozalloc_abort.cpp:33
01:35:27     INFO -  <<<<<<<
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1370448
You need to log in before you can comment on or make changes to this bug.