GetPageX() and GetPageY() shouldn't use nsIScrollableView COMPtrs

VERIFIED DUPLICATE of bug 166804

Status

()

P3
normal
VERIFIED DUPLICATE of bug 166804
17 years ago
16 years ago

People

(Reporter: kinmoz, Assigned: joki)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I've been seeing some pages that generate lots of warnings like this in the 
console:

WARNING: not supported for views, file y:\mozilla\view\src\nsScrollPortView.cpp,
 line 113

when moving the mouse around over the content area. http://my.netscape.com is an 
example of a page that can cause this warning to show up.

It seems to be caused by the fact that the nsDOMEvent.cpp implementations of 
GetPageX() and GetPageY() use nsCOMPtr<nsIScrollableView>. Views in the view 
system are not refcounted at all so you'll notice throughout the product people 
are using raw pointers (like nsIScrollableView*) when dealing with views and 
just not releasing them.

Should GetPageX() and GetPageY() follow suit?

Comment 1

16 years ago
No idea how important this is, can someone please take a look?
Priority: -- → P3
fixed for a while now...

*** This bug has been marked as a duplicate of 166804 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.