Closed Bug 1371331 Opened 2 years ago Closed 2 years ago

Show the "search with" prefix on search suggestions on mousehover

Categories

(Firefox :: Address Bar, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox55 + verified

People

(Reporter: mak, Assigned: mak)

References

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

When the user selects a search suggestion in the location bar we show the "-- search with Engine". This allows the user to more easily distinguish them.

With the new mousehover style we don't show the prefix anymore for mouse interaction, but we should, both for the selected entry and the hovered entry.
Sounds like something we should fix before the 55 release.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Comment on attachment 8876103 [details]
Bug 1371331 - Show the 'search with Engine' suffix for Location Bar search results on mousehover.

https://reviewboard.mozilla.org/r/147532/#review152090

Good catch.
Attachment #8876103 - Flags: review?(adw) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/53bc47324ae0
Show the 'search with Engine' suffix for Location Bar search results on mousehover. r=adw
https://hg.mozilla.org/mozilla-central/rev/53bc47324ae0
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
I have reproduced this bug with Nightly 55.0a1 (2017-06-08) on Ubuntu 16.04, 64 bit!

The fix is now verified on Latest Nightly.

Build ID 	20170613100218
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170614]
I have successfully reproduced this bug with Nightly 55.0a1 (2017-06-08) (32-bit)  on windows 10(32bit)

this bug is verified fix with  latest Nightly 56.0a1 (2017-06-13) (32-bit)

Build ID: 20170613030203
Mozilla/5.0 (Windows NT 10.0; rv:56.0) Gecko/20100101 Firefox/56.0
As per Comment 6 and Comment 7, I am marking this bug as verified fixed.
Status: RESOLVED → VERIFIED
Let's make sure this works as intended on macOS 10.12.5 and Windows 7 as well. Flagging for additional regression testing.
Flags: qe-verify+
I reproduced this issue using Fx 55.0a1 (build ID: 20170608030205) on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 55.0b2 on Windows 10 x64, macOS X 10.12.6 and Ubuntu 14.04 LTS.

Cheers!
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.