Closed Bug 1371570 Opened 7 years ago Closed 6 years ago

Ubuntu 17.04 VM on Fusion Virtual Hardware Version 12 cause black screen when webrender is enabled

Categories

(Core :: Graphics: WebRender, defect, P5)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected

People

(Reporter: cbook, Unassigned)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(3 files)

Attached image screenshot
Steps to reproduce:
-> VMware Fusion latest Version (Version 8.5.7 (5528452) at this time)
-> Ubuntu 17.04 with all updates etc
-> VMware tools / open-vm-tools installed
-> Firefox trunk Debug Build from taskcluster
-> export MOZ_WEBRENDER=1
-> start Firefox 

--> kind of black items on screen - firefox unsuable  (see attached screenshot)

also in the terminal

ATTENTION: default value of option force_s3tc_enable overridden by environment.
[Parent 2595] WARNING: GLX_swap_control unsupported, ASAP mode may still block on buffer swaps.: file /home/worker/workspace/build/src/gfx/gl/GLContextProviderGLX.cpp, line 218
[GLX] window 3400010 has VisualID 0x17f
[2634] WARNING: '!compMgr', file /home/worker/workspace/build/src/xpcom/components/nsComponentManagerUtils.cpp, line 63
[Parent 2595] WARNING: Robustness supported, strategy is not LOSE_CONTEXT_ON_RESET!: file /home/worker/workspace/build/src/gfx/gl/GLContext.cpp, line 1003
[Parent 2595] WARNING: robustness marked as unsupported: file /home/worker/workspace/build/src/gfx/gl/GLContextFeatures.cpp, line 926
WebRender - OpenGL version new 3.3 (Core Profile) Mesa 17.0.3

with export MOZ_WEBRENDER=0 Firefox works as expected so there seems to be a problem somehow
Attached file about:support
note that downgrading the virtual hardware version cause a startup crash with the STR - Bug 1371563
I can reproduce on MBP15 late-2013 model.

Firefox turns black immediately after launched into homepage with webrender enabled.

This issue only happens when hardware acceleration in VMWare fusion is enabled.

So maybe it is a compatibility issue with VM's GFX backend.
See also https://bugzilla.mozilla.org/show_bug.cgi?id=1352574#c3

As with bug 1371563, unless this is blocking something important it's going to be a P5 for the time being.
Priority: -- → P5
Whiteboard: [gfx-noted]
Can you post glxinfo from inside the VM?
Attached file glxinfo
(In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> Can you post glxinfo from inside the VM?

attached :)
Ok. It looks like the vm is just using llvmpipe. WebRender should work in that situation so I'm not sure what's going wrong here.
:Tomcat's account is disabled now. We cannot get an info from the reporter.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: