Closed Bug 1371606 Opened 5 years ago Closed 4 years ago

Folders can't be uploaded to Dropbox

Categories

(Core :: DOM: Copy & Paste and Drag & Drop, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Tracking Status
platform-rel --- ?
firefox-esr52 --- verified
firefox53 --- verified
firefox54 --- verified
firefox55 --- verified
firefox59 --- verified
firefox60 --- verified
firefox61 --- verified

People

(Reporter: emilghitta, Unassigned)

Details

(Whiteboard: [platform-rel-Dropbox])

Attachments

(1 file)

Attached image Dropbox issue 2.gif
[Affected versions]:
Firefox 55.0a1 (Build Id:20170608030205)
Firefox 54.0 (Build Id:20170605134926)
Firefox 53.0.3 (Build Id:20170518000419)
Firefox 52.2.0esr (Build Id:20170607123825)

[Affected platforms]:
 Mac OS X 10.11.6
 Ubuntu 14.04 32bit.
 Windows 10 64 bitt.


[Steps to reproduce]:
1. Launch Firefox with a clean profile.
2. Access the https://www.dropbox.com webpage.
3. Log in.
4. Drag a folder (not an empty one) in order to upload it.

[Expected result]:
The folder is successfully uploaded.

[Actual result]:
The file is not uploaded and an error is displayed stating that "This folder or empty file could not be uploaded because of browser limitations".


[Regression range]:
This doesn't seem like a regression since it is reproducible even with old Firefox 47.0a1.

[Additional notes]:
Please observe the attached video for more information.
Firefox 47.0a1 didn't support directory dnd, but >=50 does.
And it was working https://bugzilla.mozilla.org/show_bug.cgi?id=1293949#c29
This sounds like a bug in Dropbox.
I informed Dropbox about this.
platform-rel: --- → ?
Whiteboard: [platform-rel-Dropbox]
This appears to be fixed. Tested in Firefox 61 OSX, I can upload a folder containing files to Dropbox.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
The issue is verified fixed using Firefox 59.0.2 RC under Windows 10 (x64), Ubuntu 16.04 (x64) and macOS 10.13. Folders can be successfully uploaded to Dropbox.
You need to log in before you can comment on or make changes to this bug.