js parent.close closes whole window instead of one tab in tabbed mode

VERIFIED DUPLICATE of bug 103452

Status

VERIFIED DUPLICATE of bug 103452
17 years ago
10 years ago

People

(Reporter: gracjan, Assigned: jag-mozilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Reproduce:

1. Open some tabs
2. In one of them open
http://www.w3schools.com/xsl/tryxsl.asp?filename=cdcatalog_choose
3. Click the "Close" button

Happened: whole window closed.
Expected: closed only one tab.

Seems like in tabbed browsing mode if there are frames, then top level frames
have the parent property set to whole window instead of the tab.

Mozilla 0.9.9, Win2K

Comment 1

17 years ago
Reassigning to DOM Level 0, though this is a duplicate of a bug
I will now search for.

This is not a JavaScript Engine issue. JavaScript Engine deals with the
abstract JavaScript programming language. Specifically, the low-level 
objects such as String(), Number(), and Date(). The JS Engine is not itself 
aware of browser or DOM objects like window, document, sockets, etc.
Assignee: rogerl → jst
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → DOM Level 0
Ever confirmed: true
QA Contact: pschwartau → desale

Comment 2

17 years ago
Found the dupe: bug 103452 
"javascript window.close should close tab, not complete browser window"

Let me reassign to Tabbed Browser component for parity -
Assignee: jst → jaggernaut
Component: DOM Level 0 → Tabbed Browser
QA Contact: desale → sairuh

Comment 3

17 years ago
Gracjan: thank you for this report. You will be cc'ed on the duplicate bug -

*** This bug has been marked as a duplicate of 103452 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.