Closed Bug 1371710 Opened 3 years ago Closed 2 years ago

Places should not be initialized before first paint

Categories

(Toolkit :: Places, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: florian, Assigned: florian)

References

Details

Attachments

(1 file, 2 obsolete files)

The code in nsBrowserGlue.js causing places to be initialized before we create the first browser window seems to be doing it by accident.
Attached patch Patch (obsolete) — Splinter Review
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attached patch Patch v2 (obsolete) — Splinter Review
Try was green-ish for attachment 8876185 [details] [diff] [review] except for the startup test in which my blacklist was a bit too agressive:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=b1594de7529d88e9cccf58ae3525e7c6357b1c7b

Here is a try push of the new version with the fixed blacklist:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=85838b5ba04bd3f959ef07de7a41a6ed6de5ffa5

I think this is now ready for review.
Attachment #8876312 - Flags: review?(mconley)
Attachment #8876185 - Attachment is obsolete: true
Comment on attachment 8876312 [details] [diff] [review]
Patch v2

Review of attachment 8876312 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8876312 - Flags: review?(mconley) → review+
I'll be eager to see what, if anything, this does to our ts_paint numbers. I'm 60% confident that we'll see an improvement.
I'm failing to make the tests pass on Windows, and giving up, given that Marco is actively working on bug 1371677 which should help a lot.
My current investigations show that on try on Windows some C++ code is starting places when we load a page from a JAR file (I suspect about:newtab).
Attachment #8876312 - Attachment is obsolete: true
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d3d1741941f
Places should not be initialized before first paint, r=mconley.
https://hg.mozilla.org/mozilla-central/rev/2d3d1741941f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Depends on: 1373387
Blocks: 1386445
Duplicate of this bug: 1361091
You need to log in before you can comment on or make changes to this bug.