Closed Bug 1371995 Opened 2 years ago Closed 2 years ago

"New Tab" is cut off / doesn't fade out in loading tabs

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 56
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- verified
firefox55 blocking verified
firefox56 --- verified

People

(Reporter: dao, Assigned: ehsan)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image Screenshot
[Tracking Requested - why for this release]: recent regression affecting primary UI
Tracked for 55. If we can get a fix landed by 1pm PST today, I'd like to include this in 55.0b1.
This bug is due to the fact that the CSS selectors added in bug 1357656 do not select anything if there is no dir attribute on the tab-label-container element.  That is the case when the tab has no title yet (when we display the New Tab string in the tab title), that is before _setTabTitle() has ever been called.  In that case, the string is coming from the browser localization, so we should be abiding by the locale direction.
Assignee: nobody → ehsan
(In reply to Ritu Kothari (:ritu) from comment #1)
> Tracked for 55. If we can get a fix landed by 1pm PST today, I'd like to
> include this in 55.0b1.

How should I land it for 55?  Should I request uplift?  Or something else?
Flags: needinfo?(rkothari)
Comment on attachment 8876753 [details] [diff] [review]
Use the browser UI direction to set the fade-out direction for the New Tab string in tab titles

See the approval request in bug 1357656, this needs to be uplifted alongside it for 54.0.1.
Attachment #8876753 - Flags: approval-mozilla-release?
Comment on attachment 8876753 [details] [diff] [review]
Use the browser UI direction to set the fade-out direction for the New Tab string in tab titles

Review of attachment 8876753 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, this fixes the issue for me (and doesn't re-open bug 1357656).
Attachment #8876753 - Flags: review?(mconley) → review+
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/be5745a13ea4
Use the browser UI direction to set the fade-out direction for the New Tab string in tab titles; r=mconley
(In reply to :Ehsan Akhgari (needinfo please, extremely long backlog) from comment #3)
> (In reply to Ritu Kothari (:ritu) from comment #1)
> > Tracked for 55. If we can get a fix landed by 1pm PST today, I'd like to
> > include this in 55.0b1.
> 
> How should I land it for 55?  Should I request uplift?  Or something else?

Yes, please nominate the fix for uplift to m-b and m-r. I'll A+ m-b landing today. For m-r, we'll take it when we are closer to gtb 54.0.1
Flags: needinfo?(rkothari)
Comment on attachment 8876753 [details] [diff] [review]
Use the browser UI direction to set the fade-out direction for the New Tab string in tab titles

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1357656
[User impact if declined]: Comment 0
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: Not really, I've tested it
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Because it's simple
[String changes made/needed]: None
Attachment #8876753 - Flags: approval-mozilla-beta?
Comment on attachment 8876753 [details] [diff] [review]
Use the browser UI direction to set the fade-out direction for the New Tab string in tab titles

Recent regression, Beta55+
Attachment #8876753 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/mozilla-central/rev/be5745a13ea4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Flags: qe-verify+
I can confirm this is fixed on latest Nightly (56.0a1 (2017-06-13)), Windows 10.
Status: RESOLVED → VERIFIED
Reproduced this issue on Nightly 55.0a1 (2017-06-11) using Ubuntu 16.04 x64.

This bug is also verified on 55.0b2 (20170615133456) on the following OSes: Win 10 x64, Ubuntu 16.04 x64 and Mac OS X 10.11.6.
Comment on attachment 8876753 [details] [diff] [review]
Use the browser UI direction to set the fade-out direction for the New Tab string in tab titles

Fix a tab regression. Release54+. Should be in 54.0.1.
Attachment #8876753 - Flags: approval-mozilla-release? → approval-mozilla-release+
Please read bug 1357656 comment 50 before uplifting to the release repository.  Thanks in advance!
Setting for verification in 54.0.1 as well.
Flags: qe-verify+
Verified fixed on 54.0.1 (20170628075643) as well, across platforms: Win 10 x64, Mac OS X 10.11.6 and Ubuntu 14.04 x64 LTS.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.