Closed Bug 1372243 Opened 2 years ago Closed Last year

Crash in libX11.so.6.3.0@0x41d5b

Categories

(Core :: Graphics, defect, P3)

55 Branch
Unspecified
Linux
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox55 --- wontfix
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- affected

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, steps-wanted, testcase-wanted, Whiteboard: [gfx-noted])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-89c29ea2-95ec-444d-a90c-a2b7b0170514.
=============================================================

Seen while looking at crash stats - these Linux crashes seem to go back to 20170511133312: http://bit.ly/2rneewr

Maybe the correlations tab can help here, didn't see any URLs yet.
At a minimum, this seems to be only occurring with OpenGL layers being used, which is not enabled by default.

Also, unless I'm interpreting the reports wrong, it looks like they're all coming from the same user.

I did a cursory glance of the teardown code therein, and I couldn't spot anything obvious going wrong. It would help if we could find some STR or testcase for this.
Severity: critical → normal
Priority: -- → P3
Whiteboard: [gfx-noted]
Socorro shows 9 installs/17 crashes on one of the 2 signatures, so I think it is more than 1 user crashing.
I beg your pardon that I generated so many crash reports (between 90 and 100). I will disable the GPU process after I have sent this message.

To help you out I compiled a nightly Firefox with debug symbols. Today I was finally lucky to catch a core dump of the crashing GPU process. The attached file has information about the core dump, a backtrace and a full backtrace. If it helps, I can try to upload the complete core dump to bugzilla (4.9M, lz4 compressed).

Here’s the crash report that was automatically generated: https://crash-stats.mozilla.com/report/index/43be6b3c-1d43-4981-b447-ade511170620

How to reproduce:
 * Install Fedora 26
 * Download and unpack Firefox nightly
 * Start Firefox
 * Force-enable the GPU process
 * Restart Firefox

The GPU process crashes within the first 30 seconds which is not visible for the user. The browser works as expected, it just generates crash reports. It doesn’t happen on every browser start.

Just ask if you need any information.
bp-27ebdab1-395f-4f88-8a7c-4343d0170621 [@ libX11.so.6.3.0@0x4259b ] a standalone crash from today. can't remember if I noticed a crash. but network.disable.ipc.security is default now and does not longer appear along to a [@ mozilla::net::NeckoParent::GetValidatedOriginAttributes ].

Other crashs I had today and often:
bp-a9a63a95-1c06-4004-b989-0a0b70170620 [@ mozalloc_abort | abort | webrender::texture_cache::TextureCache::insert ] 
= bug 1352092

bp-d037725b-bb02-45be-a090-8061d0170621 [@ mozilla::gfx::DrawTarget::PushLayer ] 
= bug 1373304

In the last days I also had similar crashes which do not have a bug yet.
bp-b677272d-61a9-46b3-a0ea-e797f0170614 [@ @0x405b17 ]
bp-34fa4b5f-b52c-4e84-980f-27a040170614 [@ @0x405ab7 ]
bp-36de30f3-93b8-4d90-998c-2fe990170610 [@ @0x405ab7 ]
bp-dda82670-04c9-4d8a-9706-2887b0170610 [@ libX11.so.6.3.0@0x4259b ]

bp-253ed072-8f9f-48c0-bfb6-54eee0170610 [@ libxul.so@0x10f0cf9 | gfxPlatform::GetPlatform ]
bp-ef9b5b14-5010-460a-9699-0e68d0170610 [@ libxul.so@0x10fbe19 | gfxPlatform::GetPlatform ]
those two have: MOZ_RELEASE_ASSERT(!XRE_IsGPUProcess()) (GFX: Not allowed in GPU process.)
Nightly 58 x64 20171104100412 de_DE @ Debian Testing (KDE, Radeon RX480)
gpu process, layers force accel, no webrender (forgot it), blob-images (wihout effect), omtp, stylo-chrome

Meldungs-ID 	Sendedatum
bp-8300d544-3031-417a-a01a-093090171104 04.11.17 23:32 [@ libX11.so.6.3.0@0x4259b ]
bp-f5bc9099-2c37-420a-8535-5195a0171104 04.11.17 22:45 [@ libX11.so.6.3.0@0x4259b ]

My perception is that I can get this crash signature - with and without WebRender - when closing Nightly (and when WebRender crashs).
The crash stack has changed a bit over time. Especially this line is 'new':

> 5 	libxul.so 	mozilla::layers::CompositorManagerParent::DeallocPCompositorBridgeParent 	gfx/layers/ipc/CompositorManagerParent.cpp:272
Has STR: --- → no
See Also: → 1415020
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.