Nightly: Unclickable horizontal line across the top of some windows

VERIFIED FIXED in Firefox 56

Status

()

Firefox
Tabbed Browser
P1
normal
VERIFIED FIXED
2 months ago
2 months ago

People

(Reporter: Caspy7, Assigned: Oriol)

Tracking

({regression})

55 Branch
Firefox 56
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

(Whiteboard: [photon-visual])

Attachments

(3 attachments)

(Reporter)

Description

2 months ago
I update Nightly daily and today after updating I noticed that some, but not all of my windows have a horizontal 2 pixel line across the top edge.

Tested in safe mode and the issue persisted. Another Nightly user on IRC, also on Windows 10, reported having the same thing (others did not).

The notably irritating issue here is that I keep my browser windows full screen and naturally push my mouse to the top of the screen to click on a tab, which no longer works. This has made selecting tabs a chore.
Thanks for reporting, Caspy7. Do you have a screenshot you can post?
Flags: needinfo?(caspy77)
Keywords: regression
(Reporter)

Comment 2

2 months ago
Created attachment 8876798 [details]
Screenshot Demonstrating horizontal line
Flags: needinfo?(caspy77)
(Reporter)

Comment 3

2 months ago
Created attachment 8876799 [details]
Screenshot Demonstrating No line (for comparison)
Thanks Caspy7. Hey Dao, is this a known regression?
Flags: needinfo?(dao+bmo)
(Reporter)

Comment 5

2 months ago
It was pointed out earlier by Philipp that the prior changeset was pretty limited.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=799d43edb324395cf02da6b028e803712334615f&tochange=27cad9749cddf68e11fdd4e5d73dad84a8f8cf23

This is assuming that the malicious change didn't somehow manifest later than when it landed.

Also, I just updated to 56 and the issue is still present.
(Reporter)

Comment 6

2 months ago
I just discovered that if I click and drag this line down that it acts like a maximized window titlebar (the same as the new drag square on the left) where you click and pull down and now it becomes windowed/non-maximized.

Updated

2 months ago
Blocks: 1185482
Flags: needinfo?(dao+bmo)
Whiteboard: [photon-visual][triage]

Updated

2 months ago
status-firefox54: --- → unaffected
status-firefox55: --- → affected
status-firefox56: --- → affected

Updated

2 months ago
Flags: qe-verify+
Priority: -- → P2
QA Contact: brindusa.tot
Whiteboard: [photon-visual][triage] → [photon-visual]
Hi Dão, does this live on Nightly for now? How much do we concern this issue for 55 release?
Flags: needinfo?(dao+bmo)

Comment 8

2 months ago
Caspy7, what are your Windows DPI settings?
status-firefox55: affected → unaffected
Flags: needinfo?(dao+bmo) → needinfo?(caspy77)
(Reporter)

Comment 9

2 months ago
Assuming you're talking about the "Change the size of text, app, and other item" setting it's 150%.
http://i.imgur.com/AH3hBPT.png
If you're talking about layout.css.dpi, it's -1.

As a side note, I saw this marked 55 unaffected, but will point out I observed this in the last build of 55, however, I'm guessing it's photon related which would exempt non-nightly builds for now.
Flags: needinfo?(caspy77)
(Reporter)

Comment 10

2 months ago
In case it's a helpful datapoint, I tried shutting down Firefox and setting zoom to 100% and restarting but this did not help. Additionally I tried doing the same but renaming xulstore.json (also to no avail).

Comment 11

2 months ago
When i set my DPI setting to 100%, this bug is present in Firefox Release too.
(Assignee)

Comment 12

2 months ago
This happens to me when the window is created non-maximized.

1. Make current window non-maximized
2. Open a new (non-maximided) window with Ctrl+N
3. Maximize the new window, there is this problem.

But if the window is created maximized, then it works well.
(Assignee)

Comment 13

2 months ago
Created attachment 8878249 [details] [diff] [review]
titlebar.patch

OK, the problem is that #titlebar is 32px tall but only has -31px margin-bottom.

Therefore, the tabs don't fully overlap it, 1px remains above.

This is because the code used Math.min but I think Math.max is more appropriate.
Assignee: nobody → oriol-bugzilla
Status: NEW → ASSIGNED
Attachment #8878249 - Flags: review?(dao+bmo)

Updated

2 months ago
Priority: P2 → P1
Comment on attachment 8878249 [details] [diff] [review]
titlebar.patch

Thanks! This seems to make sense, although I can't really test it since I can't reproduce the bug.
Attachment #8878249 - Flags: review?(dao+bmo) → review+

Comment 15

2 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d4fa07225921
Remove 1px gap above tabs in maximzed windows. r=dao
(Assignee)

Updated

2 months ago
Keywords: checkin-needed
Keywords: checkin-needed

Comment 16

2 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d4fa07225921
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
status-firefox56: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56

Updated

2 months ago
Iteration: --- → 56.1 - Jun 26
(Reporter)

Comment 17

2 months ago
I'm still seeing this on today's build, but per the landing time in comment 16, should it have been included?
(Assignee)

Comment 18

2 months ago
(In reply to Caspy7 from comment #17)
> I'm still seeing this on today's build, but per the landing time in comment
> 16, should it have been included?

Yes, and the problem is fixed for me in nightly 56.0a1 2017-06-17 build bb8eab3c3ac4147848c4c85d628ba72029978665

Now I see comment 0 says 2px but I only had 1px. So maybe you still have something which produces that extra pixel?
(Assignee)

Comment 19

2 months ago
Caspy7, if you still have the problem, can you set devtools.chrome.enabled=true, open the browser console (Ctrl+Shift+J) and post the result of this code:

{let {boxSizing, marginTop, borderTopWidth, paddingTop, height, paddingBottom, borderBottomWidth, marginBottom} = getComputedStyle(document.getElementById('titlebar')); JSON.stringify({boxSizing, marginTop, borderTopWidth, paddingTop, height, paddingBottom, borderBottomWidth, marginBottom, y: document.getElementById('tab-view-deck').getBoundingClientRect().y}, null, 2)}

Before my patch I got

{
  "boxSizing": "border-box",
  "marginTop": "0px",
  "borderTopWidth": "0px",
  "paddingTop": "8px",
  "height": "40px",
  "paddingBottom": "0px",
  "borderBottomWidth": "0px",
  "marginBottom": "-31px",
  "y": 9
}

And now it's

{
  "boxSizing": "border-box",
  "marginTop": "0px",
  "borderTopWidth": "0px",
  "paddingTop": "8px",
  "height": "39px",
  "paddingBottom": "0px",
  "borderBottomWidth": "0px",
  "marginBottom": "-31px",
  "y": 8
}
Flags: needinfo?(caspy77)
(Reporter)

Comment 20

2 months ago
Welp, for some reason Nightly was not updating properly since Friday (the 16th). It *appeared* to update, but then things got wonky on updating till it finally linked me to the manual installer.

After an update it appears that this issue is fixed.
Status: RESOLVED → VERIFIED
Flags: needinfo?(caspy77)

Updated

2 months ago
Flags: qe-verify+
status-firefox-esr52: --- → unaffected

Comment 21

2 months ago
Operating System:Windows 10 x64
Firefox version:Nightly 52.0a.1

I have tested this bug in my latest nightly browser and it cannot be reproduced.
This Bug has been resolved and fixed.


[bugday-20170628]
You need to log in before you can comment on or make changes to this bug.