document.load() should be able to load documents with non-XML mime type

RESOLVED DUPLICATE of bug 194176

Status

()

Core
XML
RESOLVED DUPLICATE of bug 194176
16 years ago
15 years ago

People

(Reporter: Heikki Toivonen (remove -bugzilla when emailing directly), Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Apparently IE can do this. It should be pretty straight forward to do this
(using the same trick as was done with XMLHttpRequest and overrideMimeType()
method, but we need to figure out if the override should be always on, and what
kind of document does IE give you if you try to load HTML or text or something...).
*** Bug 137280 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
Changing QA Contact
QA Contact: petersen → rakeshmishra
There are already many cases where Mozilla requires a proper Content-Type even
though IE tries to apply DWIM. Why would Mozilla "support" bad server
configuration in this particular case?
QA Contact: rakeshmishra → petersen
It is not only server issue, if you try to load an XML file with .foo extension
from your local disc it would also fail.

Also, document.load() is Microsoft extension, so we should try to follow them as
closely as possible.

Comment 5

16 years ago
Changing Q/A contact
QA Contact: petersen → rakeshmishra
Boris is working on DOM 3 Load & Save, so he might fix this in the process.
Target Milestone: --- → Future

*** This bug has been marked as a duplicate of 194176 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.