Can't block/unblock Amazon ad image.

RESOLVED DUPLICATE of bug 33583

Status

()

RESOLVED DUPLICATE of bug 33583
17 years ago
16 years ago

People

(Reporter: jbn, Assigned: bugzilla)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I'm using a new profile on 2002041003 and I can't block or unblock the Amazon ad
below the site logo; neither choice is listed in the context menu.

To reproduce:
1. Open Mozilla, make a new profile, and go to
http://www.nizkor.org/features/fallacies/ then let it load.
2. Right-click on the ad just below the Nizkor image (it was an Amazon ad for me).
3. Notice that neither block nor unblock is listed.

I had Javascript and Java turned off for all sites.

Comment 1

17 years ago
wfm build 2002041221 on Linux

It's the 7. item in the list ("Block images from this Server") in my build..

Comment 2

17 years ago
The banner isn't a usual IMG:

< script
src="http://rcm.amazon.com/e/cm?t=thenizkorproject&l=rc1&p=3&o=1"
type="text/JavaScript">
< / script >

The script produces a table, consisting of a table/text and a IMG.
The IMG *can* be blocked!
As the function is called "Block images from Server" and not
"Block Scripts from Server" this should be ok...
(Reporter)

Comment 3

17 years ago
Actually, I mentioned I didn't have Javascript on.  Therefore my Mozilla acted
on the following markup:

<noscript>

<table border="0" cellpadding="0" width="392" height="67"
cellspacing="0"><tr><td>
<map NAME="bannermap"><area SHAPE="RECT" COORDS="305, 54, 390, 66"
HREF="http://rcm.amazon.com/e/cm/privacy-policy.html?o=1">
<area COORDS="0,0,10000,10000"
HREF="http://www.amazon.com/exec/obidos/redirect-home/thenizkorproject"></map>
<img
src="http://rcm-images.amazon.com/images/G/01/associates/amzn_recommends/gnbox392x67.gif"
width="392" height="67" border="0" usemap="#bannermap">
</td></tr></table>

</noscript>

But it's still an image map inside a table.  But in this case there is no way to
block the image from the context menu.  Turn off all Javascript and see for
yourself.  Be sure you're testing with the Amazon ad.  Other ads don't have this
same markup.

Comment 4

17 years ago
Yes, you're right. Sorry...
When removing the 'usemap="#bannermap"' portion of the
IMG-Tag, blocking works. So this seems to cause the problem...
fallout from the context menu landing...  Clicking within an <area> gives the
link menu and not the linked image menu.
Assignee: morse → blaker
Blocks: 135841
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 7

17 years ago

*** This bug has been marked as a duplicate of 33583 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
No longer blocks: 135841

Updated

16 years ago
QA Contact: tever → nobody
You need to log in before you can comment on or make changes to this bug.