bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Acc layer enters strings converted with CSS's text-convert.

RESOLVED WONTFIX

Status

()

Core
Disability Access APIs
RESOLVED WONTFIX
a year ago
10 months ago

People

(Reporter: Mario Batusic, Unassigned)

Tracking

(Blocks: 1 bug)

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

Our website uses style="text-convert:uppercase" for some strings such as Author names for articles. 
W3C/WAI recommends using this technique for all-capitals because the accessibility tree should contain pure html strings with small or only capitelized words. The problem is, that many screen reader speech output engenes read the uppercase strings letter-by-letter and not normal.
Component: Untriaged → Disability Access APIs
Product: Firefox → Core
A test file or URL would be helpful. With all the screen readers out there, it is not clear to me whether we actually have a bug in Firefox.
Blocks: 368895
I think this bug should be fixed on the AT side.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.