Intermittent TEST-UNEXPECTED-TIMEOUT | /xhr/send-response-upload-event-progress.htm | XMLHttpRequest: The send() method: Fire a progress event named progress on the XMLHttpRequestUpload (synchronous flag is unset) - Test timed out

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
a year ago
3 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

Trunk
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell disabled])

1 failures in 814 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-06-12&endday=2017-06-18&tree=all
2 failures in 892 pushes (0.002 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 2

Platform breakdown:
* linux64-stylo: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-06-19&endday=2017-06-25&tree=all
3 failures in 718 pushes (0.004 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 2
* mozilla-central: 1

Platform breakdown:
* linux64-stylo: 2
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-06-26&endday=2017-07-02&tree=all
9 failures in 656 pushes (0.014 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-central: 4
* mozilla-inbound: 2
* oak: 1
* mozilla-beta: 1
* autoland: 1

Platform breakdown:
* windows8-64: 5
* windows7-32-vm: 3
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-07-03&endday=2017-07-09&tree=all
3 failures in 720 pushes (0.004 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-central: 2
* autoland: 1

Platform breakdown:
* windows8-64: 2
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-07-10&endday=2017-07-16&tree=all
7 failures in 822 pushes (0.009 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 5
* autoland: 2

Platform breakdown:
* windows8-64: 3
* windows7-32: 3
* windows10-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-07-17&endday=2017-07-23&tree=all
Assignee: nobody → shuang
I can reproduce timeout on linux using rr.
10 failures in 1008 pushes (0.01 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 6
* mozilla-inbound: 3
* mozilla-central: 1

Platform breakdown:
* windows10-64: 5
* windows8-64: 3
* windows7-32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-07-24&endday=2017-07-30&tree=all
6 failures in 888 pushes (0.007 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 4
* mozilla-inbound: 2

Platform breakdown:
* windows7-32: 3
* windows10-64: 2
* linux64-stylo: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-07-31&endday=2017-08-06&tree=all
29 failures in 901 pushes (0.032 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 20
* mozilla-inbound: 4
* mozilla-central: 3
* try: 1
* mozilla-beta: 1

Platform breakdown:
* windows10-64-stylo: 8
* windows10-64: 8
* windows7-32: 6
* windows7-32-stylo: 5
* windows8-64: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-08-07&endday=2017-08-13&tree=all
15 failures in 188 pushes (0.08 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 5
* mozilla-central: 4
* mozilla-inbound: 3
* try: 2
* mozilla-beta: 1

Platform breakdown:
* windows10-64: 8
* windows10-64-stylo: 3
* windows7-32-stylo: 2
* windows7-32: 1
* linux64-stylo: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-08-16&endday=2017-08-16&tree=all
48 failures in 949 pushes (0.051 failures/push) were associated with this bug in the last 7 days. 

This is the #29 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 20
* mozilla-inbound: 12
* mozilla-central: 8
* try: 4
* mozilla-beta: 4

Platform breakdown:
* windows10-64: 22
* windows7-32: 11
* windows10-64-stylo: 8
* windows7-32-stylo: 3
* linux64-stylo: 2
* windows10-64-devedition: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-08-14&endday=2017-08-20&tree=all
this failure has increased in frequency in the last 2 weeks and it would be nice to fix this or disable it.

:shawnjohnjr, I see this is assigned to you, can you look into fixing this sometime in the next week or two?
Flags: needinfo?(shuang)
Whiteboard: [stockwell needswork]
(In reply to Joel Maher ( :jmaher) (UTC-5) from comment #13)
> this failure has increased in frequency in the last 2 weeks and it would be
> nice to fix this or disable it.
> 
> :shawnjohnjr, I see this is assigned to you, can you look into fixing this
> sometime in the next week or two?

Yes. I will take a look in the next week. I'm working on P1 bug this week so I can't work this bug immediately.
Flags: needinfo?(shuang)
31 failures in 908 pushes (0.034 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 16
* mozilla-inbound: 6
* try: 4
* mozilla-central: 4
* mozilla-beta: 1

Platform breakdown:
* windows10-64: 14
* windows7-32: 9
* windows10-64-stylo: 3
* windows7-32-stylo: 2
* windows10-64-nightly: 1
* linux64-stylo: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-08-21&endday=2017-08-27&tree=all
I can't reproduce this bug using rr. So I will add more logs to try-server.
It seems the frequency is much higher than bug 1370056. I will investigate this bug first.
43 failures in 939 pushes (0.046 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 21
* mozilla-inbound: 10
* try: 5
* mozilla-beta: 4
* mozilla-central: 3

Platform breakdown:
* windows10-64: 20
* windows7-32: 11
* windows10-64-stylo: 7
* windows7-32-stylo: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-08-28&endday=2017-09-03&tree=all
It looks like the same problem as bug 1370056 used.
As I mentioned in bug 1370056 comment 20, in normal situation, onProgress() will be executed after open() and before load event gets issued, and set mProgressSinceLastProgressEvent to true, then progress event will be sent in OnStartRequest(). In bad situation, it seems onProgress() event delay a bit, and we check the current state is in headers_received so we don't fire progress event.  OnProgress is triggered by nsBaseChannel::OnDataAvailable, it seems like necko doesn't trigger onProgress in time. Then load event was sent first. I have to check why OnDataAvailable doesn't call in time.
(In reply to Shawn Huang [:shawnjohnjr] from comment #19)
> It looks like the same problem as bug 1370056 used.
typo: s/used/had
It looks like the same problem as bug 1370056 had.
DispatchProgressEvent to upload object only happened in both OnStartRequest and HandleProgressTimerCallback. Even to allow to check mState is headers_received in InUploadPhase, HandleProgressTimerCallback doesn't trigger anyway.
Switch to critical 56 beta bug a few days, now I'm focusing this again.
59 failures in 924 pushes (0.064 failures/push) were associated with this bug in the last 7 days. 

This is the #39 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 33
* mozilla-inbound: 8
* mozilla-central: 8
* mozilla-beta: 6
* try: 4

Platform breakdown:
* windows10-64-stylo-disabled: 20
* windows10-64: 15
* windows7-32: 10
* windows7-32-stylo-disabled: 7
* windows7-32-stylo: 2
* windows10-64-stylo: 2
* linux32: 2
* windows7-32-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-09-04&endday=2017-09-10&tree=all
3 failures in 191 pushes (0.016 failures/push) were associated with this bug yesterday.    

** This test has failed more than 200 times in the last 30 days. It should be disabled until it can be fixed. ** 

Repository breakdown:
* autoland: 2
* try: 1

Platform breakdown:
* windows10-64-stylo-disabled: 2
* windows10-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-09-14&endday=2017-09-14&tree=all
Whiteboard: [stockwell needswork] → [stockwell disable-recommended]
37 failures in 1032 pushes (0.036 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 22
* try: 5
* mozilla-central: 5
* mozilla-inbound: 3
* mozilla-beta: 2

Platform breakdown:
* windows10-64: 14
* windows10-64-stylo-disabled: 9
* windows7-32: 6
* windows7-32-stylo-disabled: 5
* windows7-32-devedition: 1
* osx-10-10: 1
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-09-11&endday=2017-09-17&tree=all
disabled this test case:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ba64cdc57937720873e9a096de3f892b817c5873

:shawnjohnjr, please remember to enable this in the manifest when you fix this.
Flags: needinfo?(shuang)
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
(In reply to Joel Maher ( :jmaher) (UTC-5) from comment #26)
> disabled this test case:
> https://hg.mozilla.org/integration/mozilla-inbound/rev/
> ba64cdc57937720873e9a096de3f892b817c5873
> 
> :shawnjohnjr, please remember to enable this in the manifest when you fix
> this.

Sorry. I'm again stuck in blockers now. I will revisit these issues again.
Flags: needinfo?(shuang)
5 failures in 943 pushes (0.005 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-release: 4
* autoland: 1

Platform breakdown:
* windows10-64: 3
* windows7-32: 1
* windows10-64-stylo-disabled: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-09-18&endday=2017-09-24&tree=all
3 failures in 885 pushes (0.003 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-release: 3

Platform breakdown:
* windows10-64: 2
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-09-25&endday=2017-10-01&tree=all
1 failures in 912 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-release: 1

Platform breakdown:
* windows10-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1373347&startday=2017-10-23&endday=2017-10-29&tree=all
Assignee: shuang → nobody
Component: web-platform-tests → DOM
Product: Testing → Core
Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | /XMLHttpRequest/send-response-upload-event-progress.htm | XMLHttpRequest: The send() method: Fire a progress event named progress on the XMLHttpRequestUpload (synchronous flag is unset) - Test timed out → Intermittent TEST-UNEXPECTED-TIMEOUT | /xhr/send-response-upload-event-progress.htm | XMLHttpRequest: The send() method: Fire a progress event named progress on the XMLHttpRequestUpload (synchronous flag is unset) - Test timed out
Version: Version 3 → Trunk
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Priority: -- → P3
Resolution: --- → WORKSFORME
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.