Closed Bug 1373375 Opened 2 years ago Closed 2 years ago

SeaMonkey extensions and themes are flagged as legacy in add-ons manager.

Categories

(SeaMonkey :: General, enhancement)

SeaMonkey 2.52 Branch
enhancement
Not set

Tracking

(seamonkey2.48 unaffected, seamonkey2.49esr unaffected, seamonkey2.50 unaffected, seamonkey2.51 unaffected, seamonkey2.52 wontfix, seamonkey2.53 fixed)

RESOLVED FIXED
seamonkey2.53
Tracking Status
seamonkey2.48 --- unaffected
seamonkey2.49esr --- unaffected
seamonkey2.50 --- unaffected
seamonkey2.51 --- unaffected
seamonkey2.52 --- wontfix
seamonkey2.53 --- fixed

People

(Reporter: frg, Assigned: frg)

Details

Attachments

(1 file, 1 obsolete file)

In Nightly all extensions and themes are flagged as legacy. This should not happen for the ones distributed with SeaMonkey.
Attached patch 1373375-extensionslegacy.patch (obsolete) — Splinter Review
Not so sure if the startup scope should be extended to 15 but some code for directory scans was recently removed from toolkit. TB currently uses 4.
Attachment #8878184 - Flags: review?(iann_bugzilla)
Comment on attachment 8878184 [details] [diff] [review]
1373375-extensionslegacy.patch

> // Disable add-ons installed into the shared user and shared system areas by
> // default. This does not include the application directory. See the SCOPE
> // constants in AddonManager.jsm for values to use here.
> pref("extensions.autoDisableScopes", 15);
> 
>+// Enable add-ons installed and owned by the application, like the default theme.
Does the comment match the value, it seems to only describe if it was 4.
>+pref("extensions.startupScanScopes", 15);
Have you tested against different values? Is 4 sufficient?

>+
>+pref("extensions.legacy.enabled", true);
>+// Extensions that should not be flagged as legacy in about:addons
>+// {972ce4c6-7e08-4474-a285-3208198ce6fd} default theme
>+// {59c81df5-4b7a-477b-912d-4e0fdf64e5f2} chatZilla
>+// {e2fda1a4-762b-4020-b5ad-a41df1933103} calendar
>+pref("extensions.legacy.exceptions", "{972ce4c6-7e08-4474-a285-3208198ce6fd},debugQA@mozilla.org,modern@themes.mozilla.org,inspector@mozilla.org,{59c81df5-4b7a-477b-912d-4e0fdf64e5f2},{e2fda1a4-762b-4020-b5ad-a41df1933103}");
Should we also include DOMi?

r=me with those addressed.
Attachment #8878184 - Flags: review?(iann_bugzilla) → review+
> Have you tested against different values? Is 4 sufficient?

Unsure. I will need to retest it. A comment from Jorg in the TB bug indicated that 15 is maybe necessary.

> Should we also include DOMi?

It is already in: inspector@mozilla.org. I put only the extensions with id as the name in the comment for clarification.

I am not sure about langauge packs but Fx do not seem to have them in the pref yet.
4 should be sufficient. But I forgot to include the MOZ_ALLOW_LEGACY_EXTENSIONS build var (which is 1 now but you never know) so asking for review again.
Attachment #8878184 - Attachment is obsolete: true
Attachment #8881235 - Flags: review?(iann_bugzilla)
Comment on attachment 8881235 [details] [diff] [review]
1373375-extensionslegacy-V2.patch

r=me
Attachment #8881235 - Flags: review?(iann_bugzilla) → review+
https://hg.mozilla.org/comm-central/rev/ccbd9c80a4ddd761cc7e7c24c3886cf8412bda35
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.53
Duplicate of this bug: 1365170
You need to log in before you can comment on or make changes to this bug.