Feature Request - WebExtensions: Allow for horizontal panels distinct from DevTools

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
2 years ago
7 months ago

People

(Reporter: alanc, Unassigned)

Tracking

54 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [design-decision-denied])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170608105825

Steps to reproduce:

Need a topbar/bottombar feature to insert panels above or below the browser window pane for extension content.  This was supported with browser overlays prior to WebExtensions.

Panels could be always on or on demand.  horizontal orientation of these panes allows for content that isn't suited to sidebar format (tabular data, wider content, etc.)

These could be implemented with all the sidebar functionality, but simple container functionality would be satisfactory.

It seems that the design philosophy now is to do this via DevTools, but I see no reason to have to force a DevTools interface on the users to get a horizontal pane.  Many will find that confusing.
Severity: normal → enhancement
Component: Untriaged → WebExtensions: Frontend
Product: Firefox → Toolkit
Whiteboard: [design-decision-needed]
Hi A Capesius, this has been added to the agenda for the July 11 WebExtension APIs triage meeting. Would you be able to join us? 

Wiki: https://wiki.mozilla.org/Add-ons/Contribute/Triage#Next_Meeting

Agenda: https://docs.google.com/document/d/1MEMC7EyZ2VVInbWod7FD2SFGp36osoxQkhUm5f0aNSs/edit#
Flags: needinfo?(amckay)

Comment 2

2 years ago
Sorry, this took me a while to comment on, but this seems highly unlikely. We are specifically trying to reduce the amount of vertical space available to content not decrease it. An area of content available to extensions that is independent of the content is there in the sidebar.

The argument I heard in the meeting was that this won't work because its not wide enough. Whilst that might be true, creating, maintaining and support this doesn't seem worth the effort.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(amckay)
Resolution: --- → WONTFIX
Whiteboard: [design-decision-needed] → [design-decision-denied]

Comment 3

2 years ago
Oops: "We are specifically trying to *increase* the amount of vertical space available to content not decrease it"
(Reporter)

Comment 4

2 years ago
Seems this is a more generalized form of what is already implemented for the Developer's Tools panel, which also demonstrates the need for horizontal layout in some situations.

Comment 5

a year ago
Am I right that this API would be necessary to create a Vimperator clone? (see the panel in https://addons.cdn.mozilla.net/user-media/previews/full/58/58920.png)
(Reporter)

Comment 6

a year ago
> Am I right that this API would be necessary to create a Vimperator clone?

Yes, Vimperator also uses a XUL overlay to create an extension-level panel outside the current page context.

Comment 7

a year ago
> Sorry, this took me a while to comment on, but this seems highly unlikely. We are specifically trying to [increase] the amount of vertical space available to content not decrease it. An area of content available to extensions that is independent of the content is there in the sidebar.

I'd like to disagree with this. Many monitors are full HD nowadays, or even wider. This means that my monitor is wide enough to have two windows next to each other, and many (if not all) operating systems/window managers specifically cater for this use case as a feature in their window manager (dragging windows to the side to make them fill half the screen is pretty common). The result of this is that my window is higher than it is wide, and I do not have any horizontal pixels to spare. Moreover, websites are usually created with vertical scrolling in mind, but break down completely with a lack of horizontal space. This means that decreasing the available vertical space for a website generally has less of a usability impact than decreasing the horizontal space.

Updated

7 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.