Ensure the resizing architecture for Photon panels can work asynchronously

VERIFIED WORKSFORME

Status

()

Firefox
Toolbars and Customization
VERIFIED WORKSFORME
6 months ago
3 months ago

People

(Reporter: Paolo, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [triage])

(Reporter)

Description

6 months ago
I was experimenting with how we can use async functions instead of callback-based functions in panelmultiview, and came across an issue with views initializing asynchronously.

I added a simple "await Promise.resolve();" after the point in PanelMultiView.jsm where we wait for the "blockers" registered by the ViewShowing event.

If I do this, there are glitches when opening the "More" subview of the panel menu, that are more noticeable the first time, but still present afterwards.

This will likely influence subviews that are asynchronous, like the History subview when it's used from the new Library menu in the toolbar, and should be fixed. This is difficult see right now because of an issue with the main view starting too small in the Library menu.
(Reporter)

Comment 1

6 months ago
Mike, do you see this too?
Flags: needinfo?(mdeboer)

Comment 2

6 months ago
Paolo, I think this is a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=1370580, see discussion there, particularly comment 7 and later, and https://reviewboard.mozilla.org/r/147596/diff/3-4/ .
(In reply to :Gijs from comment #2)
> Paolo, I think this is a dupe of
> https://bugzilla.mozilla.org/show_bug.cgi?id=1370580, see discussion there,
> particularly comment 7 and later, and
> https://reviewboard.mozilla.org/r/147596/diff/3-4/ .

Indeed. The updated patch in there should kick things back into gear.
Flags: needinfo?(mdeboer)

Comment 4

6 months ago
Is this still an issue, Paolo, or should we dupe this to bug 1370580?
Flags: needinfo?(paolo.mozmail)
(Reporter)

Comment 5

6 months ago
I think it's still an issue for the main panel if you follow the steps in comment 0. In other words, it's a bug in the resizing architecture that may hit us in the future, but does not currently happen. It seems related to views that are smaller than the main view, asynchronous, and is particularly visible the first time they are shown.
Flags: needinfo?(paolo.mozmail)

Comment 6

3 months ago
I think this was fixed by the most recent animation changes. Mike or Paolo, can you verify?
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(paolo.mozmail)
Flags: needinfo?(mdeboer)
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
Flags: needinfo?(paolo.mozmail)
Flags: needinfo?(mdeboer)
You need to log in before you can comment on or make changes to this bug.