If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

regression: gradient bleeds with background-attachment: fixed

RESOLVED DUPLICATE of bug 929484

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 929484
3 months ago
3 months ago

People

(Reporter: Nick Pope, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 months ago
Created attachment 8878420 [details]
screenshot of regression

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170613235745

Steps to reproduce:

Added a background gradient to a table row with background-attachment: fixed.

This has been working fine until Firefox 54. All platforms affected.

See https://jsfiddle.net/qtkkokkt/1/ or attached files.


Actual results:

The background gradient renders incorrectly and bleeds out to the first parent container with a non-visible value for the overflow property. There are three different coloured rows - the colour of the last overrides the others and alpha is not applied.


Expected results:

Background gradient should be constrained to the table row and alpha should be applied.
(Reporter)

Comment 1

3 months ago
Created attachment 8878426 [details]
screenshot of expected rendering
(Reporter)

Comment 2

3 months ago
Created attachment 8878427 [details]
simple example of regression

Comment 3

3 months ago
Fixed in 55+.
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=33df8c04309cf792b214c5c6c903a391048f5516&tochange=0f95b12c599465afb36f64e268dd42bbbbafbfe1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 929484
You need to log in before you can comment on or make changes to this bug.