Closed Bug 1373792 Opened 3 years ago Closed 3 years ago

WebExtensions Tab scripts

Categories

(WebExtensions :: Untriaged, defect)

53 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1318532

People

(Reporter: futpib, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749

Steps to reproduce:

Tried to implement "Responsive Design Mode"-like add-on as a WebExtension


Actual results:

Found no WebExtensions API that allows one to wrap a page in an `iframe` or `xul:browser`-like thingy


Expected results:

There is any API for that. Probably similar to Content scripts, except outside the page (one window/realm "above" content page)
andy looking for a dupe related to moz browsing
Flags: needinfo?(amckay)
This sounds like bug 1318532 would work for you.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(amckay)
Resolution: --- → DUPLICATE
Duplicate of bug: 1318532
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.