Closed Bug 1373858 Opened 3 years ago Closed 3 years ago

Intermittent dom/media/tests/mochitest/test_peerConnection_stats.html | candidate-pair.bytesSent was tested.

Categories

(Core :: WebRTC, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mjf)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:logic])

Attachments

(2 files)

this is primarily on autophone, but also seen on other platforms as well.  Seems to be consistent since June 16th (3 days, 34 failures)

:mreavy- I see you as the triage owner for this component, could you find someone from the webRTC team to look into this and help resolve this in the next 2 weeks?
Flags: needinfo?(mreavy)
Whiteboard: [stockwell needswork]
:bc, could we disable this on autophone for the time being?  That would reduce the failures, 28 total yesterday and 17 were on autophone.
Flags: needinfo?(bob)
Just this one test? Sure.
well there could be others, but this one test seems to be failing quite often.
I don't think we need a try run, do you?
Flags: needinfo?(bob)
Attachment #8879904 - Flags: review?(jmaher)
Comment on attachment 8879904 [details] [diff] [review]
bug-1373858.patch

Review of attachment 8879904 [details] [diff] [review]:
-----------------------------------------------------------------

thanks; I don't think we need a try run, worse case scenario the failure is related to something else and we will see more failures in another test in this directory.
Attachment #8879904 - Flags: review?(jmaher) → review+
Whiteboard: [stockwell needswork] → [stockwell needswork][leave open]
Pushed by bclary@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7dc1aafc5eff
Disable dom/media/tests/mochitest/test_peerConnection_stats.html for Android failures, r=jmaher.
Rank: 35
Priority: -- → P3
ok, disabling on android didn't solve the problem, since we have a 62 failures on non android, it would be nice if we could get someone from the team to look at this- I will disable this on my wednesday cleanup if there is no action here.
(In reply to Joel Maher ( :jmaher) from comment #14)
> ok, disabling on android didn't solve the problem, since we have a 62
> failures on non android, it would be nice if we could get someone from the
> team to look at this- I will disable this on my wednesday cleanup if there
> is no action here.

Sorry - I don't know how I missed this particular bug.  It is additional fallout from the previous Orange factor fix I made, and is timing-related.  Please give me a day or two to look at it, as this is the first I'd heard about it rising up in the results.
Assignee: nobody → mfroman
Apologies that this took so long to get to Michael.  Thanks for taking this, Michael.
Flags: needinfo?(mreavy)
thanks :mjf, let me know if you have troubles reproducing this or need more information.
Comment on attachment 8882374 [details]
Bug 1373858 - make sure all fields are checked in the cancelled pairs.

https://reviewboard.mozilla.org/r/153478/#review158656

::: dom/media/tests/mochitest/test_peerConnection_stats.html:379
(Diff revision 1)
>          ok(stat.framesEncoded >= 0 && stat.framesEncoded < 100000, stat.type
>            + ".framesEncoded is a sane number for a short test. value="
>            + stat.framesEncoded);
>        }
>      } else if (stat.type == "candidate-pair") {
> +      info("candidate-pair is: " + JSON.stringify(stat));

Do you want to keep this, or is that development debug message only?

::: dom/media/tests/mochitest/test_peerConnection_stats.html:418
(Diff revision 1)
>  
>        // state
> -      if (stat.state == "succeeded") {
> +      if (stat.state == "succeeded" &&
> +          stat.selected !== undefined &&
> +          stat.selected) {
> +        info("candidate-pair state is succeeded and selected is true");

Same question here.
Attachment #8882374 - Flags: review?(drno) → review+
Comment on attachment 8882374 [details]
Bug 1373858 - make sure all fields are checked in the cancelled pairs.

https://reviewboard.mozilla.org/r/153478/#review158656

> Do you want to keep this, or is that development debug message only?

Yeah, I debated on this, but ultimately decided to leave it in case other bugs come up here.

> Same question here.

Ditto above.
Pushed by mfroman@nostrum.com:
https://hg.mozilla.org/integration/autoland/rev/2a0702d83512
make sure all fields are checked in the cancelled pairs. r=drno
we might want to enable this on autophone as well since we disabled it there not too long ago to reduce the failures here.
Whiteboard: [stockwell needswork][leave open] → [stockwell fixed:logic]
https://hg.mozilla.org/mozilla-central/rev/2a0702d83512
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.