Build fails with system-libvpx and system-jpeg enabled in mozconfig

RESOLVED FIXED in Firefox 56

Status

()

Core
Build Config
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: shalokshalom, Assigned: dminor)

Tracking

55 Branch
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170613173134

Steps to reproduce:

Build with the default mozconfig on KaOS or Arch - i guess others are also effected


Actual results:

This error message(s) appeared

(USE_LIBS contains (media_libjpeg) / (media_libvpx) which does not match any LIBRARY_NAME in the tree.)



Expected results:

Build finished fine.

Updated

4 months ago
Component: Untriaged → Build Config
Product: Firefox → Core
(Reporter)

Comment 1

4 months ago
Created attachment 8878833 [details]
mozconfig

mozconfig file with the mentioned entries commented out
https://dxr.mozilla.org/mozilla-beta/rev/b08a305464d127e25fab19f358fac15fceb52954/media/webrtc/trunk/gtest/moz.build#29,31
> USE_LIBS += [
> ...
>     'media_libjpeg',
> ...
>     'media_libvpx',

I guess these lines should be inside a branch on CONFIG['MOZ_SYSTEM_JPEG'] or CONFIG['MOZ_SYSTEM_LIBVPX'].

Updated

4 months ago
Blocks: 964133
(Assignee)

Updated

4 months ago
Assignee: nobody → dminor
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 3

4 months ago
Created attachment 8879131 [details] [diff] [review]
Check for system libjpeg and libvpx in webrtc gtest moz.build
Attachment #8879131 - Flags: review?(mh+mozilla)
Comment on attachment 8879131 [details] [diff] [review]
Check for system libjpeg and libvpx in webrtc gtest moz.build

Review of attachment 8879131 [details] [diff] [review]:
-----------------------------------------------------------------

::: media/webrtc/trunk/gtest/moz.build
@@ +43,5 @@
>      'yuv',
>  ]
>  
> +if not CONFIG['MOZ_SYSTEM_JPEG']:
> +    USE_LIBS += ['media_libjpeg']

That will still fail, albeit with a different error, because of the missing linkage of the system jpeg and vpx libraries.

I think we need something similar to what's done with config/external/*/moz.build (e.g. sqlite)
Attachment #8879131 - Flags: review?(mh+mozilla)
(Assignee)

Comment 5

4 months ago
Created attachment 8879503 [details] [diff] [review]
Check for system libjpeg and libvpx in webrtc gtest moz.build

Yes, I foolishly didn't let the build run to completion once I saw it get past the errors mentioned.

This patch does build on my (Ubuntu) system both with and without --with-system-jpeg and --with-system-libvpx set.
Attachment #8879131 - Attachment is obsolete: true
Attachment #8879503 - Flags: review?(mh+mozilla)
Comment on attachment 8879503 [details] [diff] [review]
Check for system libjpeg and libvpx in webrtc gtest moz.build

Review of attachment 8879503 [details] [diff] [review]:
-----------------------------------------------------------------

This fixes the immediate problem, but I still think we need something like config/external/sqlite/moz.build. Please file a followup bug.
Attachment #8879503 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 7

4 months ago
Thanks! Filed Bug 1375178.

Comment 8

4 months ago
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4bc36447fcf4
Make webrtc-gtest build work with system jpeg and libvpx; r=glandium
We'll want this uplifted to beta. Can you do the request?

Comment 10

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4bc36447fcf4
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.