Slow regex compilation in the beginning of speedometer run

RESOLVED DUPLICATE of bug 1373195

Status

()

defect
RESOLVED DUPLICATE of bug 1373195
2 years ago
2 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
This doesn't get a JS pseudostack for some reason.

http://bit.ly/2sKyVHK

Looks like most of the time is spent in GetCaseIndependentLetters().

Note that I'm not certain if this time falls inside the span of the time that the test suite measures directly.
See bug 1373195.

This shows up as particularly bad with Callgrind, so it's interesting you saw it in a "real" profile. I wasn't sure if Callgrind made it seem worse than it actually is.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1373195
You need to log in before you can comment on or make changes to this bug.