MLK: nsTextFragment::SetTo()

VERIFIED DUPLICATE of bug 13735

Status

()

P2
critical
VERIFIED DUPLICATE of bug 13735
19 years ago
19 years ago

People

(Reporter: bruce, Assigned: buster)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Solaris 2.6, gcc 2.7.2.3.  Build from September 13, 1999.  Opened viewer, loaded
initial page, went to www.visa.com, selected the 'back to school' specials link,
quit.

MLK: 15 bytes leaked at 0x946d98
  * This memory was allocated from:
        malloc         [rtlib.o]
        __bUiLtIn_nEw  [libraptorgfx.so]
        __builtin_new  [rtlib.o]
        __bUiLtIn_vEc_nEw [libraptorgfx.so]
        __builtin_vec_new [rtlib.o]
        nsTextFragment::SetTo(const unsigned short*,int)
[nsTextFragment.cpp:147]
        nsAttributeContent::ValidateTextFragment() [nsAttributeContent.cpp:415]
        nsAttributeContent::GetText(const nsTextFragment*&,int&)
[nsAttributeContent.cpp:427]
        nsTextTransformer::Init(nsIFrame*,int) [nsTextTransformer.cpp:86]
        nsTextFrame::PrepareUnicodeText(nsTextTransformer&,int*,unsigned
short*,int*) [nsTextFrame.cpp:621]

nsTextFrame::PaintAsciiText(nsIPresContext*,nsIRenderingContext&,nsIStyleContext*,nsTextFrame::TextStyle&,int,int)
[nsTextFrame.cpp:1502]
        nsTextFrame::Paint(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsTextFrame.cpp:597]
        nsContainerFrame::PaintChild(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsIFrame*,nsFramePaintLayer) [nsContainerFrame.cpp:313]

nsContainerFrame::PaintChildren(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsContainerFrame.cpp:253]
        nsHTMLContainerFrame::Paint(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsHTMLContainerFrame.cpp:84]
        nsContainerFrame::PaintChild(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsIFrame*,nsFramePaintLayer) [nsContainerFrame.cpp:313]
        nsBlockFrame::PaintChildren(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsBlockFrame.cpp:5291]
        nsBlockFrame::Paint(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsBlockFrame.cpp:5226]
        nsAreaFrame::Paint(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsAreaFrame.cpp:222]
        nsContainerFrame::PaintChild(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsIFrame*,nsFramePaintLayer) [nsContainerFrame.cpp:313]

nsContainerFrame::PaintChildren(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsContainerFrame.cpp:253]

nsHTMLButtonControlFrame::Paint(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsHTMLButtonControlFrame.cpp:411]
        nsContainerFrame::PaintChild(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsIFrame*,nsFramePaintLayer) [nsContainerFrame.cpp:313]
        nsBlockFrame::PaintChildren(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsBlockFrame.cpp:5291]
        nsBlockFrame::Paint(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsBlockFrame.cpp:5226]
        nsAreaFrame::Paint(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsAreaFrame.cpp:222]
        nsContainerFrame::PaintChild(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsIFrame*,nsFramePaintLayer) [nsContainerFrame.cpp:313]
        nsBlockFrame::PaintChildren(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsBlockFrame.cpp:5291]
        nsBlockFrame::Paint(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsFramePaintLayer) [nsBlockFrame.cpp:5226]
        nsContainerFrame::PaintChild(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsIFrame*,nsFramePaintLayer) [nsContainerFrame.cpp:313]
(Reporter)

Comment 1

19 years ago
an addtional purify trace:

MLK: 11 bytes leaked at 0x80ff40
  * This memory was allocated from:
        malloc         [rtlib.o]
        __bUiLtIn_nEw  [libraptorgfx.so]
        __builtin_new  [rtlib.o]
        __bUiLtIn_vEc_nEw [libraptorgfx.so]
        __builtin_vec_new [rtlib.o]
        nsTextFragment::SetTo(const unsigned short*,int)
[nsTextFragment.cpp:147]
        nsAttributeContent::ValidateTextFragment() [nsAttributeContent.cpp:415]
        nsAttributeContent::GetText(const nsTextFragment*&,int&)
[nsAttributeContent.cpp:427]
        nsTextTransformer::Init(nsIFrame*,int) [nsTextTransformer.cpp:86]
        nsTextFrame::Reflow(nsIPresContext&,nsHTMLReflowMetrics&,const
nsHTMLReflowState&,unsigned int&) [nsTextFrame.cpp:2368]
        nsLineLayout::ReflowFrame(nsIFrame*,nsIFrame**,unsigned int&)
[nsLineLayout.cpp:904]
        nsInlineFrame::ReflowInlineFrame(nsIPresContext*,const
nsHTMLReflowState&,nsInlineFrame::InlineReflowState&,nsIFrame*,unsigned int&)
[nsInlineFrame.cpp:1557]
        nsInlineFrame::ReflowInlineFrames(nsIPresContext*,const
nsHTMLReflowState&,nsInlineFrame::InlineReflowState&,nsHTMLReflowMetrics&,unsigned
int&) [nsInlineFrame.cpp:1392]
        nsInlineFrame::Reflow(nsIPresContext&,nsHTMLReflowMetrics&,const
nsHTMLReflowState&,unsigned int&) [nsInlineFrame.cpp:1308]
        nsLineLayout::ReflowFrame(nsIFrame*,nsIFrame**,unsigned int&)
[nsLineLayout.cpp:904]

nsBlockFrame::ReflowInlineFrame(nsBlockReflowState&,nsLineLayout&,nsLineBox*,nsIFrame*,unsigned
char*) [nsBlockFrame.cpp:3204]

nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState&,nsLineLayout&,nsLineBox*,int*,unsigned
char*) [nsBlockFrame.cpp:3095]

nsBlockFrame::DoReflowInlineFramesAuto(nsBlockReflowState&,nsLineBox*,int*,unsigned
char*) [nsBlockFrame.cpp:3039]
        nsBlockFrame::ReflowInlineFrames(nsBlockReflowState&,nsLineBox*,int*)
[nsBlockFrame.cpp:2988]
        nsBlockFrame::ReflowLine(nsBlockReflowState&,nsLineBox*,int*,int)
[nsBlockFrame.cpp:2260]
        nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)
[nsBlockFrame.cpp:2003]
        nsBlockFrame::Reflow(nsIPresContext&,nsHTMLReflowMetrics&,const
nsHTMLReflowState&,unsigned int&) [nsBlockFrame.cpp:1307]
        nsAreaFrame::Reflow(nsIPresContext&,nsHTMLReflowMetrics&,const
nsHTMLReflowState&,unsigned int&) [nsAreaFrame.cpp:344]

nsContainerFrame::ReflowChild(nsIFrame*,nsIPresContext&,nsHTMLReflowMetrics&,const
nsHTMLReflowState&,unsigned int&) [nsContainerFrame.cpp:439]

nsHTMLButtonControlFrame::Reflow(nsIPresContext&,nsHTMLReflowMetrics&,const
nsHTMLReflowState&,unsigned int&) [nsHTMLButtonControlFrame.cpp:544]

nsGfxButtonControlFrame::Reflow(nsIPresContext&,nsHTMLReflowMetrics&,const
nsHTMLReflowState&,unsigned int&) [nsGfxButtonControlFrame.cpp:182]
        nsLineLayout::ReflowFrame(nsIFrame*,nsIFrame**,unsigned int&)
[nsLineLayout.cpp:904]

nsBlockFrame::ReflowInlineFrame(nsBlockReflowState&,nsLineLayout&,nsLineBox*,nsIFrame*,unsigned
char*) [nsBlockFrame.cpp:3204]

nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState&,nsLineLayout&,nsLineBox*,int*,unsigned
char*) [nsBlockFrame.cpp:3095]

nsBlockFrame::DoReflowInlineFramesAuto(nsBlockReflowState&,nsLineBox*,int*,unsigned
char*) [nsBlockFrame.cpp:3039]

Updated

19 years ago
Assignee: troy → kipp

Updated

19 years ago
Severity: normal → critical
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M11

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
Same underlying bug - portions of the content model are leaking.


*** This bug has been marked as a duplicate of 13735 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
Based on kipp's comments, marking as verified duplicate of 13735.

Comment 4

19 years ago
Based on kipp's comments, marking as verified duplicate of 13735.
You need to log in before you can comment on or make changes to this bug.