Closed Bug 1374337 Opened 2 years ago Closed 8 months ago

Create test for verifying scalars across multiple sessions

Categories

(Toolkit :: Telemetry, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1502849
Tracking Status
firefox57 --- unaffected

People

(Reporter: Silne30, Assigned: raphael)

References

Details

Attachments

(1 file)

1. Open Browser
2. Open New Tab
3. Perform Search
  a. Verify search scalars
4. Restart Browser in new session
  a. Verify that the session Id has changed
  b. There should be a previous session ID
  c. There should be no previous subsession ID
  d. There should be no subsessionID
  e. Verify that a ping is received for previous session 
5. Install addon
  a. Verify that there should be no listing for tab scalar as we started a new 
     session
6. Perform Search 
7. Restart Browser in the same session
  a. Verify that a subsession starts
  b. There should be a previousSessionID
  c. There should be no previousSubsessionID
  d. Verify that session ID is still the same
  e. Verify scalars have reset
Priority: -- → P4
Assignee: nobody → jdorlus
Blocks: 1352196
Attachment #8882778 - Flags: review?(rpappalardo)
Comment on attachment 8882778 [details]
Bug 1374337 - Added Test for verifying scalars over multiple sessions

Removed rpapa from review since we need the test to be reviewed by someone with L3 access.
Attachment #8882778 - Flags: review?(rpappalardo)
Clearing left-over assignee.
Assignee: jsdorlus → nobody
Assignee: nobody → rpierzina
Priority: P4 → P2
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1502849
You need to log in before you can comment on or make changes to this bug.