Closed Bug 1374597 Opened 4 years ago Closed 4 years ago

Extension error: TypeError: this.browser is null resource://gre/modules/ExtensionTabs.jsm 294

Categories

(WebExtensions :: Frontend, defect, P2)

defect

Tracking

(firefox57 affected)

RESOLVED WORKSFORME
Tracking Status
firefox57 --- affected

People

(Reporter: kanru, Unassigned)

References

Details

While testing Nightly, I saw a lot of error like this

Extension error: TypeError: this.browser is null resource://gre/modules/ExtensionTabs.jsm 294
[[Exception stack
get frameLoader@resource://gre/modules/ExtensionTabs.jsm:294:5
get frameLoader@chrome://browser/content/ext-utils.js:496:5
get width@chrome://browser/content/ext-utils.js:545:5
convert@resource://gre/modules/ExtensionTabs.jsm:491:7
convert@resource://gre/modules/ExtensionTabs.jsm:1664:12
listener@chrome://browser/content/ext-tabs.js:116:24
runSafeSyncWithoutClone@resource://gre/modules/ExtensionUtils.jsm:52:14
emit/promises<@resource://gre/modules/ExtensionUtils.jsm:238:55
emit@resource://gre/modules/ExtensionUtils.jsm:237:20
emitCreated@chrome://browser/content/ext-utils.js:406:5
handleEvent/<@chrome://browser/content/ext-utils.js:256:13
waitForSyncCallback@resource://services-common/async.js:98:7
makeSpinningCallback/callback.wait@resource://services-common/async.js:168:27
promiseSpinningly@resource://services-common/async.js:234:12
createRecord@resource://services-sync/engines/bookmarks.js:807:16
_createRecord@resource://services-sync/engines.js:954:18
_createRecord@resource://services-sync/engines/bookmarks.js:543:18
_reconcile@resource://services-sync/engines.js:1556:23
recordHandler@resource://services-sync/engines.js:1201:23
_processIncoming@resource://services-sync/engines.js:1241:9
_processIncoming@resource://services-sync/engines/bookmarks.js:514:7
_sync@resource://services-sync/engines.js:1807:7
WrappedNotify@resource://services-sync/util.js:160:21
sync@resource://services-sync/engines.js:723:5
_syncEngine@resource://services-sync/stages/enginesync.js:219:7
sync@resource://services-sync/stages/enginesync.js:166:15
onNotify@resource://services-sync/service.js:1088:7
WrappedNotify@resource://services-sync/util.js:160:21
WrappedLock@resource://services-sync/util.js:116:16
_lockedSync@resource://services-sync/service.js:1078:12
sync/<@resource://services-sync/service.js:1070:7
WrappedCatch@resource://services-sync/util.js:91:16
sync@resource://services-sync/service.js:1059:5
Current stack
runSafeSyncWithoutClone@resource://gre/modules/ExtensionUtils.jsm:54:129
emit/promises<@resource://gre/modules/ExtensionUtils.jsm:238:55
emit@resource://gre/modules/ExtensionUtils.jsm:237:20
emitCreated@chrome://browser/content/ext-utils.js:406:5
handleEvent/<@chrome://browser/content/ext-utils.js:256:13
waitForSyncCallback@resource://services-common/async.js:98:7
makeSpinningCallback/callback.wait@resource://services-common/async.js:168:27
promiseSpinningly@resource://services-common/async.js:234:12
createRecord@resource://services-sync/engines/bookmarks.js:807:16
_createRecord@resource://services-sync/engines.js:954:18
_createRecord@resource://services-sync/engines/bookmarks.js:543:18
_reconcile@resource://services-sync/engines.js:1556:23
recordHandler@resource://services-sync/engines.js:1201:23
_processIncoming@resource://services-sync/engines.js:1241:9
_processIncoming@resource://services-sync/engines/bookmarks.js:514:7
_sync@resource://services-sync/engines.js:1807:7
WrappedNotify@resource://services-sync/util.js:160:21
sync@resource://services-sync/engines.js:723:5
_syncEngine@resource://services-sync/stages/enginesync.js:219:7
sync@resource://services-sync/stages/enginesync.js:166:15
onNotify@resource://services-sync/service.js:1088:7
WrappedNotify@resource://services-sync/util.js:160:21
WrappedLock@resource://services-sync/util.js:116:16
_lockedSync@resource://services-sync/service.js:1078:12
sync/<@resource://services-sync/service.js:1070:7
WrappedCatch@resource://services-sync/util.js:91:16
sync@resource://services-sync/service.js:1059:5
]]

I'm not sure if this should be filed against Sync or WebExtension but this line was touched by bug 1358415.
Flags: needinfo?(kmaglione+bmo)
It looks like sync has removed most of its event loop spinning code, so if that's what's responsible, it may be fixed now.

Kan-Ru, are you still seeing this?
Flags: needinfo?(kmaglione+bmo) → needinfo?(kchen)
Priority: -- → P2
No, I can't reproduce now.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(kchen)
Resolution: --- → WORKSFORME
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.