Status

()

Core
Build Config
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: rillian, Assigned: rillian)

Tracking

unspecified
mozilla56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

MozReview Requests

()

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Assignee)

Description

6 months ago
Require rust 1.17 to unblock bindgen updates.

This is a compromise between a conservative minimum to make tier-3 support easier and the drag having to find work-arounds for new library and language features in Quantum and Stylo code.
(Assignee)

Updated

6 months ago
Assignee: nobody → giles
(Assignee)

Updated

6 months ago
Summary: Require rust 1.18 → Require rust 1.17
Ralph, just FYI, I'm working around it on bindgen in https://github.com/servo/rust-bindgen/pull/772, so this doesn't necessarily need to happen.
I believe this has been done in bug 1366542.
(Assignee)

Comment 3

6 months ago
Bug 1366542 bumped the version mach bootstrap would upgrade to (bumped to 1.18 in bug 1371366). This is about bumping the minimum version configure will accept to build with.
OK. Not sure where the minimum required version is. Stylo already doesn't build with version older than 1.17, FWIW.
Comment hidden (mozreview-request)

Comment 6

6 months ago
mozreview-review
Comment on attachment 8879750 [details]
Bug 1374807 - Require rust 1.17.

https://reviewboard.mozilla.org/r/151094/#review155976

::: build/moz.configure/rust.configure:59
(Diff revision 1)
>  
>          You can install rust by running './mach bootstrap'
>          or by directly running the installer from https://rustup.rs/
>          '''))
> -    rustc_min_version = Version('1.15.1')
> +    rustc_min_version = Version('1.17.0')
>      cargo_min_version = Version('0.{}'.format(rustc_min_version.minor + 1))

Annoying fact: we're effectively coupling cargo and rustc requirements, with cargo needing to be version 0.x+1 when rust is 1.x. I don't know how it is across distros, but while Debian has rustc 1.17 "available" (for some value of available), it only has cargo 0.17. (Ubuntu only has, at best, rustc 1.16 and cargo 0.17, btw)
(Assignee)

Comment 7

6 months ago
We do that because rustc and cargo versions _are_ coupled. They're released together, and while they both have independent features, as a driver cargo also has a dependence of changes in rustc features.

Why isn't cargo 0.18 packaged for Debian? https://tracker.debian.org/pkg/cargo doesn't really say.

Comment 8

6 months ago
mozreview-review
Comment on attachment 8879750 [details]
Bug 1374807 - Require rust 1.17.

https://reviewboard.mozilla.org/r/151094/#review156430

I grepped through the tree for "1.15.1" and saw this: https://dxr.mozilla.org/mozilla-central/source/third_party/rust/euclid/.travis.yml#3

Will we need to pull a newer version of that as well? I'm not actually sure what it is.
Attachment #8879750 - Flags: review?(mshal) → review+

Updated

6 months ago
Blocks: 1374824
(In reply to Ralph Giles (:rillian) | needinfo me from comment #7)
> Why isn't cargo 0.18 packaged for Debian?
> https://tracker.debian.org/pkg/cargo doesn't really say.

I have no idea, but it's been a PITA more than once.

(In reply to Michael Shal [:mshal] from comment #8)
> Comment on attachment 8879750 [details]
> Bug 1374807 - Require rust 1.17.
> 
> https://reviewboard.mozilla.org/r/151094/#review156430
> 
> I grepped through the tree for "1.15.1" and saw this:
> https://dxr.mozilla.org/mozilla-central/source/third_party/rust/euclid/.
> travis.yml#3
> 
> Will we need to pull a newer version of that as well? I'm not actually sure
> what it is.

That only makes that crate also test on 1.15.1 on their CI. You can build code that builds with 1.15.1 with 1.17 (and any subsequent version).

Comment 10

6 months ago
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1f6e4335dabb
Require rust 1.17. r=mshal
(Assignee)

Comment 11

6 months ago
(In reply to Michael Shal [:mshal] from comment #8)

> https://dxr.mozilla.org/mozilla-central/source/third_party/rust/euclid/.
> travis.yml#3

I filed bumps for some of these. Looks like num is testing 1.15.0 based on their own requirements. I'm not sure about arraydequeue; there's not enough info in the commit message to tell.

https://github.com/servo/euclid/pull/217
https://github.com/servo/rust-url/pull/368
https://github.com/servo/unicode-bidi/pull/41
There's webrender, too https://github.com/servo/webrender/blob/master/.travis.yml
(Assignee)

Comment 13

6 months ago
Thanks. https://github.com/servo/webrender/pull/1417

Comment 14

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1f6e4335dabb
Status: NEW → RESOLVED
Last Resolved: 6 months ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.